ArduCopter 2.7.2/2.7.3 released

Arducopter 2.7.2 is now in the mission planner and in the downloads area Some positive reports on testing can be found in this discusssion by John Hanson.

Note: just as the release was going out an issue was found re support for the all Camera Gimbals on the APM1s (it doesn't work) and with 3 axis gimbals on the APM2 (2-axis works ok but not 3).  If you're one of these people, please wait for 2.7.3 which will be out shortly. 


UPDATE: 2.7.3 is now in the Mission Planner


Functional Improvements over 2.7.1:

  • Fast waypoints (Jason) - if the turn angle between two waypoint the copter is less than 60 degrees it does not slow down
  • Navigation improvements and logging including switching to filtered location for distance calculations (jason)
  • Flip improvements - more aggressive and flexible flip code based on attitude instead of timing (Jason)
  • Improved camera control - you can now control any axis (roll, tilt, pan) with any rc channel.  it probably makes most sense that you will use 6 but others are possible too.  Unfortunately these changes required we change the set-up procedure so the mission planner gimbal set-up screen needs to be modified again.  Please refer to the AC_Camera wiki page for how to manually set-up the gimbal (Amilcar)
  • Flybar acro mode for TradHeli (Robert)
  • "Fast gains" - allows strong correction of attitude using accelerometers while the quad is stationary on the ground but relies more on gyros while flying (Tridge, Jason)
  • Baro filtering improvements (Tridge)


Bug Fixes:

  • DMP timing fix (Randy) - the MPU6000's dmp unit was inadvertantly turned on and caused timing delays in the main loop- xbee bricking issue (Craig / Tridge)
  • Dataflash fixes (Jason)
  • Engine ticking - was a combination of roll/pitch rate D term being too high and the dmp timing fix above (Randy, Emile)
  • Faster heading correction on start-up - resolves issue with simple mode getting incorrect heading if you took off very soon after start-up (Tridge)

Code Cleanup:

  • Increased maximum number parameters (Tridge)
  • Formatting changes to code (Pat)
  • Replaced "int" with "int16_t" everywhere (Randy)

As per usual PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

There is still some question on whether the default Roll/Pitch Rate P (0.175) is high enough (it was 0.185 in 2.7.1) and also some people feel the Throttle Rate should be higher (currently 0.300 but some say 0.330 or even much higher would be better).

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

Thanks and enjoy!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • What is the status of the DMP code ?   I just tried with uncommenting  #define DMP_ENABLED ENABLED in 2.7.3 and

    Apm2 hangs after boot  ,  recomment  the define and its ok again .

  • On Yesterday, I test Loiter mode by 2.7.4 at altitude 100 meters when had strong wind. It have error from set point Loiter mode about 2 meters but no oscillate. 

    2012-10-03 17-53-47.tlog

    2012-10-03 23-18 1.log

  • Randy and team

    Arducopter 2.7.4 Beta have issue in board APM 1. 

    it can't cennect telemetry Xbee on APM 1. But, APM 2.5 it can normally connect.

    pls, check and Edit a problem about telemetry Xbee on APM 1 when our used Arducopter 2.7.4 Beta.

    Best Regard 


  • There is a problem with  the updated Mission Planner. The flight data page doesn't load properly on both my computers.

  • Moderator

    Can anyone help getting the trigger function to work: I've posted an issue here:

    but maybe I'm just making a mistake somewhere?

  • hello again

       No, i definitely can't get the gimbal servos to work on anything but channels 10 and 11.

  • Hey all, 

    Didn't want to start a new thread for this as it's a very basic question, but what is the variable used inside ArduCopter to find the current roll angel?

    The one that shows as 'roll' under APM Planner. 


    (Also is there an easy way for me to determine what the variable names are inside the ArduCopter code based off their description is in the APM Planner (i.e. somehow seeing the APM Planner code to determine what they are calling to find the value)?

  • Hello,

       Is anyone else having problems assigning channels for gimbal servos.? I'm using apm2 and the latest code from the mission planner.

      I'm don't want to use channels 10 and 11 as i believe they are limited to 50hz whilst all the other channels will go to 490hz(hope this is right?)

      Anyway i've tried changing them from the gimbal set-up page and the parameters list, but the servos only work when they are assigned to 10 and 11! (and seem very slow)

       Any help would be much appreciated, i want to use high speed digital servos on my new quad

       It's an interesting design I've got high hopes for, i recommend a look!

      Thanks all, looking forward to flying this new code!

  • Well, it's been a while since I've hijacked a thread, and since I am currently very happy with APM and 2.7.4 and the upcoming fixes I thought I'd go way off topic, just to keep you entertained... 

    Although I suppose it is on topic cause next time I'm swapping the naza for an apm :)

  • Hello,

    I went to the flight field this weekend to do some tests. I have the APM 2.5 with a ublocks GPS. I had this discussion before about simple mode not getting initialized, it took me about 12 times of turning the copter on and of before alt hold not stabalize's simple mode started working and then I loaded a flight plan and it did this very successfully until the battery died.


    So I changed to a newly charged battery, and again simple mode does not want to initialize so I said screw that I am doing the flight plan again, it crashed moments after, it kept stable and was moving to the on point and then it started turning around and it head straight for the ground breaking my frames legs and some blades.


    I have 2 * APM 2.5's and 1 APM 2 and both APM 2.5's does this where simple mode does not want to get initiualized.


    Please find attached my log files




    2012-09-30 11-25-55.rlog

    2012-09-30 11-25-55.tlog
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21