Developer

ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

3691038784?profile=original

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Strangest thing happened on a 1km fpv flight yesterday...running arducopter 3.0.1 external compass..

    ... Before the flight I tested RTL, GPS etc with props off. All worked fine.
    RL is set to return at current alt.

    Around a kilometer out my RSSI was low, so I invoked RTL. ArduCopter promptly flipped the quad by turning off the motors... i took back control and righted the copter... (see 2:40 onwards)... tried RTL after that and all worked fine.. I had flown several flights this session.. all around a kilometer far and invoked RTL from 165 meters high, more than a kilometer away several times and this worked fine..
    any ideas on why this RTL turned off the motors...?

    http://youtu.be/8ZsUnPhNud0
  • T3
    Has anyone run a compassmot test on Y6? How to do you position the props? With a standard quad or hex it's simple, move 1 position over and flip the prop, But with a Y6 I'm not so sure.
    Thanks,
    Richard
  • Can anyone tell me, if when connected to mission planner by usb and with 8 sat count and hdop of 1.3 should the icon of the quad in MP be stationary as if it were loitering. My icon wanders around by 30m odd and my loiter is rubbish also. Ive done all correct setup and seem to have all figures within ranges. Ive got an APM 2 with 3.0.1 and Mediatek with latest firmware on it also.

    Not tried any loiter tuning yet, dont really want to try several flights to no avail due to bad GPS or something. It is doing a severe high speed toilet bowl maneuver around 30m diameter.

    Any help would be much appreciated

    Alex. 

  • There has been a lot of talk about the compass lately. Here are some of my findings and test results with 2.9 and 3.0 firmware.

    Please look at this post and give the community some input.

    http://www.diydrones.com/forum/topics/heading-taking-precedence-ove...

  • Hello Randy,

    Iv'e been flying my quad for a month now with no problems, running several missions and RTLs with no problems, until this morning. just bought a new batt and wondering how much flight time I would get. after retuning with the new heavier batt. I flew it outside test the copters flying attitude, love it still solid, then switch to loiter. it was solid and steady. after about 5 mins of hovering in loiter it suddenly went down, and tumbled upside down on the grass. good thing nothing is damaged.

    attached is my log, and if you have the chance, can find out what happened. thank you very much.

     

    2013-09-06 09-56-44.tlog

    2013-09-06 09-56-44.rlog

  • So the quads been flying pretty good.  The rtl speed still needs to be faster. (How do I speed it up?)  The other day I was up around 700' and I went to put it into loiter so I could get some nice video.  When I put it in loiter it started to dive.  Why did it do that?  Here is the Video  http://youtu.be/jqtWkg5cjTg  And I think I got the right log attached.  Oh and also how can I tell what the compassmot % is from the logs?

    2013-09-06 06-39 9.log

  • Hi Randy, and everyone else!

    I am flying a large coaxial machine and have noticed that my telemetry disappears as soon as I raise the throttle above idle. I am using RFD900 modems and no matter what settings I use as soon as I go above idle it drops the telemetry rate. 

    I am using apm2.5, with external compass. The modems are fine ( I have a few pairs, and all test out ok on the fixed wing) 

    My guess is that the apm 2.5 is just overworked and can't keep up with the processing of 8 motors and the telemetry.

    as soon as I drop the throttle to idle i instantly get the telemetry feed back. I need it to work for position and AP work, nxt option i guess would be to go to the PX4

    Any thoughts or things to try?

    Anyone else running a octo or quad-octo with telemetry?

    Cheers

    Steve

  • Does anyone know the default parameters for this release (Quad). Seen them before, but somehow I cannot find them....

  • Hi,

    I have had something happen recently while flying that has not happened in the past, I thought it was only on one copter but I had it happen on my second quad today. I am running the "latest" FW  I just loaded the latest FW on the second quad to see if it would happen nd it did.

    Flying in simple mode switched on via ch8 option I will be flying fine and it will go 90 degrees out of wack, forward reverse becomes right left and right left becomes forward back.

    I tried looking at the log and the compass seems ok (I should always be pointing North  in the log I will attach) so I dont know what it going on.  It will stay 90 degrees out even if I switch ch8 on and off. it stays 90 degrees out until I land, unarm then arm and take off again.

    In the log it happens once, I switch off simple mode, land and take off again.  not sure if this is a bug or what, I am using external compass's and have done compassmot  with pretty low mag field 7% on one and 8% on the other if I remember correctly.

    thanks,

    John

    2013-09-05 18-30-59.tlog

  • Hi there,

    Does anyone know when you are plugged into MP and you have a gps fix should the quad icon on the flight plan view stay still ie is this representative of the actual position the quad would be trying to achieve if in loiter. My icon seems to wander around with 9 sats and a hdop of 1.5 and my loiter is not great. Cheers Alex

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
16 hours ago
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
21 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
21 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…