ArduCopter-3.0.1 released!

ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.


4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    Is APM 1 supported or even tested with AC 3.1?? I'm still using 2.91B and like to update when 3.1 comes out.



  • Hello. Today i test 3.1-rc5 on my quad X. 450 Size, 1000kv motors.

    Autotune very good. More stability on fast land and more stability with sticks drop.

    I have some questions:

    1) What indicates YELLOW led in APM 2.5 (near blue GPS and red)?

    2) I try Acro and i do not recognize the new behavior... Very strange and not habitually. If i fly only roll or pitch - then all ok, but i fly roll and pitch - then autorotation and fast fall. If i release sticks - then copter not stay horizon and fly down and side. I not see this behavior in 3.0.1. Please give instructions how i may do behavior how in 3.0.1

    3) Battery "FailSafe" text always show in Flight data screen. I off checkbox in failsafe and alarm but i see this message again.When i off battery sensor (simple 2 resistors) in Additional hardware - then message off in Flight data. It bug or feature?

  • I did some more aggressive testing of 3.1rc5.

    After autotuning (it flew great) I decided to start playing with flips. I read across Rob's post where IIRC he liked an ACRO_RP_P of 6.5, so I decided to try 7 (hehe, from 4.5). That was interesting; you get fast flips but IMHO it becomes difficult to finesse through gaps. I normally don't run expo on my tx. So I tried dialing it all the way up to 50% and I was still over correcting all the time. So I think I'm going to fall back to 4.5 to get used to shooting gaps with the rig, then I'll carefully dial up the flip rate & expo to get a better balance of precision and quickness.

    I also got to play with Loiter, Acro, Alt, Stab, and RTL on an exceptionally windy day (25mph, with 38mph gusts). Loiter was excellent; watch the part where I loiter in front of myself. It tilted about aggressively in the swirling winds behind those trees, yet maintained a solid position. I think if I softened it up it would not look or sound so scary, but then it would probably drift in heavy winds. Early in the video I played with aggressive yaw in loiter, and as you can see the position was rock solid, and no toilet bowling even with my built in compass.

    The RTL... my control rx just so happened to failsafe in that wind. I haven't tested RTL since the recent processing speed improvements. So I decided to let it do it's thing. It flew faster toward home than I'm used to probably due to the tail wind. I'm set for 30mph lateral max, but the trip home was short so it started slowing just after it broke 20mph. The ascent and descent performance with the latest code is phenominal! The descent was now so fast it scared the c**p out of me; it took a lot of faith for me to not take over control at that point. Fortunately it stopped on a dime right in front of me, but it may take some time for me to get used to the "daring auto descent" LOL. My 'max auto z' settings are +350 and -250, which my rig seems to be able to handle well; so I'm keeping it that way. I also like the newer feature where RTL yaws to launch heading before descent; I suck at transitioning from the monitor to LOS. ;)

    Once again... cheers to the devs! :)

  • Hi all,

    Also using RC5 now :) thanks for that devs.

    I am wondering if its just me doing some wrong with the failsafe.
    In mission planner when i turn off the transmitter it allways go to LAND mode instead of RTL i have set up.
    I have enough sats 3d fix as far i can see.
    Havent used it before this failsafe, just due to bad weather i gave it a try at home without props so it isnt moving around.
    Maybe its a small bug or something?

  • You can use a 6 channel RC Txm for Autotune.
    Just plug 6th channel from RC receiver to APM's 7th pin input signal pin.
  •  Just finish running autotune and I'd like to report that it works perfect for my quad! I think v3.1 now ready for it's official release.

    Thanks to Randy, Leonard & members of Devteam!

  • spent the day testing RC5 and found that the Minim OSD no longer displays the flight mode. (I think its missing from the MAV)  No other hardware or software changes were made to the Hex other than loading 3.1 RC5.  didn't notice any other problems (REALLY liked auto tune)


    Firmware replaced was 3.0.1 ( I have not loaded or tested any other RC's, so I don't know if its a new bug or has been here a while)





  • Here is a TLOG of a failed auto tune. I've tried it many times but it always fails after about 30-40 roll iterations. Does it show in the log why it failed? I have the onboard log as well if it's needed. APM2.6 standard gps. rc5. 10" props.

    2013-10-27 14-13-25.tlog

  • It's been a while since I've actually flown my quad (been mostly just playing with the last few rc codes and not actually flying them) and I managed to do a quick hover test in my room - it's raining (again) this weekend.  ACC values look pretty good to me.  X and Y appears to be within -1 and 1 and Z within -9 and -11...


    Hopefully next weekend I'll be able to check ALT_HOLD and then attempt an AUTOTUNE... :-)  I've attached my log files if anyone might want to have a quick look at them to see if they can spot anything I havent noticed...


    2013-10-27 10-05 1.log

    2013-10-27 10-02-29.tlog

  • No longer a RED LED.

    Using vs 3.0.1 with a APM 2.5.

    Something happened and I've no Red Led. I was only connecting to fly. The GPS Blue does its thing correctly but, I've no Red. I can Arm the copter and fly it. I can Disarm, connect to MP, collect logs, change, write and refresh parameters. HUD updates normally.

    I've reflashed Firmware - I've erased EEPROM and then reconfigured. I've dismantled the copter and even with only connecting the GPS and APM to the USB still no RED. Do they burn out? I've not tried to connect external LEDs yet.

    Another unrelated oddity.

    I did notice in my search an odd situation. If you connect to the MP via USB then open a terminal window you get the datastream from the vehicle. I could not close the app and had to kill it. I restarted then connected to the vehicle through the Terminal APM connect. The APM seemed to be stuck in some loop because when I went into the Terminal and connected to download logs a stream of odd characters again streamed in the window and I could not shut down MP again without killing it. After another cycle of killing and starting the MP I did get back into the logs to download them. Yes, I know you are not supposed to connect via USB and terminal. Could you put the USB connect and disconnect button back onto the terminal screen? Often you are connected and go into terminal and with no indication or ability to disconnect you have to go to another screen to do so.

This reply was deleted.