ArduCopter 3.0.1 has been released and is now available in the Mission Planner,, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386563

Reply to This

Replies to This Discussion


No, never got further than 10 meters away.  I loaded the stable version (loaded from icon in MP) and have been flying both copters today and I haven't seen the problem at all.  Yesterday with the "latest" FW it happened 6 times in total, 5 on one copter and once on the other, both are quad's. it was happening pretty often.




If you are indoors, it doesn't matter how many satellites you have, it will wonder, the meandering track in mission planner is a trace of where the GPS thinks is the correct position,

Outdoors it will wonder for the first few minutes [depending on how long since GPS last powered up] then settle down to basically a stationary dot.

Which is why, it is a good idea before flying outdoors, connect Lipo, wait 5 minutes and then fly.

During that 5 Minutes GPS will stabilize and so will the barometer, not much power consumed at all during 5 minutes with motors not armed.

Waiting only for GPS 3D Fix then immediately taking off is NOT a good idea no matter how many satellites you have.

Has anyone run a compassmot test on Y6? How to do you position the props? With a standard quad or hex it's simple, move 1 position over and flip the prop, But with a Y6 I'm not so sure.

Just run the compassmot test with props in the same position as normal flying BUT make sure it cant move....... having to do the prop flipping is only so you can have it plugged into your computer and not have it fly away.

The only reason they tell you to do the prop flipping is so the " idiots " dont chop their fingers off and blame somebody else.

Hi James, I bought same compass.

I am looking at your photo and I would like to know how you have planned on the menù "orientation->manual".

Edit (after 1 minute): Ops, I had not seen that there was already the answer to my question;

Ciao - Giuseppe


I have a Px4 and can't seem to get it to work. Are sensors and serial on the same ports?


Richard, sent this message in the Y-6 group but here it is again.

It is done exactly the same, flip each prop over and move to the left, then repeat for the bottom. The 11"s stay on the bottom, and the 10's on top.

You can do it as Dustin recommends, but PLEASE be safe, the Y-6 has more power that one thinks,

Thanks craig. I did notice my motors on the logs. it's not the same numbers.

Is this normal?

M1 - 1200

M2 - 1210

M3 - 1195

M4 - 1198

Not sure which version you mean by 'latest'. Really, a dataflash log would really help clear this up. Not much we can do without it.

Strangest thing happened on a 1km fpv flight yesterday...running arducopter 3.0.1 external compass..

... Before the flight I tested RTL, GPS etc with props off. All worked fine.
RL is set to return at current alt.

Around a kilometer out my RSSI was low, so I invoked RTL. ArduCopter promptly flipped the quad by turning off the motors... i took back control and righted the copter... (see 2:40 onwards)... tried RTL after that and all worked fine.. I had flown several flights this session.. all around a kilometer far and invoked RTL from 165 meters high, more than a kilometer away several times and this worked fine..
any ideas on why this RTL turned off the motors...?

Hi Randy,

My friend sent some logs but is not sure which one is the motors stop flight, he thinks that must be the bigger file. Thanks for your help.




Hi,  By "latest"FW I mean the firmware in the directory "latest" from this site/page

if you go in the copter page you will see latest

the files in the latest directory are the same as the files in the latest date in the directory named by date. I think the file I was using when this happened was from this page

I want to fly with the "stable" version (the version loaded from the link in the MP) for a few days and see if this happens again. if it does not I will load up a newer FW and enable  dataflash logs and see if it happens again.

I didn't have the dataflash logs enabled when it happened, I should have turned it on but when it first happened I thought it must have been a bad/intermittent  connection to the external compass because I have noticed if the apm25 has the compass jumper cut and no external compass installed the compass readings are 90 degrees off.  then when it happened on the second copter it kind of surprised me.

I will post back either way.



Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service