ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 386504

Reply to This

Replies to This Discussion

OK,  I respect the new feature and I will try to work us, bu now, for me, is a bit difficulte to establish the exact center of the circumference.

Is there a way to return to old formulations ?

Ciao - Giuseppe

Ahhh....Geofencing needs to be enabled to save myself from myself. I did not know that. Thanks!

Any idea why the quad insisted on showing off by doing a barrel roll while in Stable mode? I've checked my vibration levels and they are good (x, y and z are .15G, .17G and .20G, respectively). Such behavior, while sometimes entertaining, is probably not desirable.

Today I tested the new firmware in my Octa.

Its is flying pretty stable until i try the loiter

I have no idea why but each time i switch to loiter Octa banks almost 90 degree instantly, in pretty aggressive maneuver. I have 3 apm 2.5 here and this is the first time i saw that behavior. I have time only to switch loiter back to stab mode and save the octa.

Anyone have an idea?

 

Pampaflyer,

     You should check the compass.  In particular try running compassmot to get an idea of how bad the interference is.  90% of the time this is the problem.

130%

:(

the interesting part is even with 130% i input 50% throttle and heading loose  around 5 degrees only.... 

Pampaflyer,

      Well, at least you know the cause of your problems!  It depends on the attitude of the copter.  rotate it 90 degrees and you may find the compass heading changes a lot.  ... and of course it's 3 dimensional interference (as is the compass vector) so the impact on heading can vary depending upon how far over the copter is rolled or pitched.

Tom,

    Looks like a mechanical failure.  The APM was no happier the copter was doing rolls than you were at least based on the desired roll vs actual roll.  I.e. the APM didn't ask it to do that!

Giuseppe,

     No way to go back to the old way I'm afraid.  The center of the circle is projected out from the front of the copter at the distance held in the CIRCLE_RADIUS parameter.

Dave,

     The 2nd half (from 20k onwards) looks pretty ok.  The first part though from 0 ~ 10k is quite messy.  If the copter really is going up and down that much then no problem but if that was a stable hover then it doesn't look good.  Is your alt hold generally ok?  if it is, then no need to worry i guess..

     The negative altitudes themself are not an issue really.  It's all relative as they say.

     the issue with dropping when switching back from loiter to stabilize (which is completely manual throttle of course) can be somewhat resolved by adjusting the thr-mid parameter (see wiki page here).

Ok, so the problem here is that that feature is only implement in AC3.1 (which isn't available yet).  So if you select the "Always Land" option you actually get RTL.

Sorry about this...it's a limitation of the way we handle the parameter descriptions.  We basically only have one set of descriptions where are always taken from "master" so unfortunately you see the feature that isn't in production yet!

Raefa,

     I think it may just be that in the first flight you were a bit higher.  The way LAND works is it uses the regular altitude hold controller to get down to 10m (so the speed is 1.5m/s or whatever is in the WPNAV_SPEED_DN parameter) and then from 10m downwards it uses the LAND_SPEED parameter which defaults to only 0.5m/s.

     So if you engage LAND from higher up it might be bouncy until the copter reaches 10m and then it will slow down and be more stable.

     You could try making WPNAV_SPEED_DN lower or higher to see if it descends better.  Some times a copter will descend more smoothly if it comes down faster....i think.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service