After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

Views: 151277

Reply to This

Replies to This Discussion

Thx, yes, I've seen that one, just wanted to see if there were any other descriptions before actually trying it.  but thx for taking time to respond! 

Ok Guys I have a very interesting problem most likely to do with the Pixhawk than the firmware .. could also have something to do with the compass cali in MP going bad.. here is my story. 

Just built a new machine (one of many) Finished set up and it was flying quite well, including a demo to the customer and interested parties.. (copter has been built for weed spraying etc) we were invited to do a demo at Scion Institute the following week , so we went down there and flew , but I noticed GPS was not holding well (copter trying to fly off) and Mag field was too low, so I could not use Loiter mode .. However upon returning home I plugged the Pixhawk (supplied by 3DR) into the Laptop and checked Mag field  and checked Compass .. weird thing was the compass did not seem to be moving correctly in the HUD .. anyway after trying several times to re calibrate the compass each time failing, I noticed the onboard compass was only showing pixels gathering on one (1) axis on the MP calibrate screen .. MMmm, so I though the compass must be corrupt ..so did a full reset and erase and started right from the beginning..once again when it came to calibrating the compass it was only showing activity on one axis on the new fancy MP Cali screen.. So I thought the compass must be DEAD, so I fitted an external Compass and redid the calibration .. having to do include the new  upside down move..and the calibration this time was fine ..I did a test flight and the Loiter held just fine , previously it would try and fly off to who knows where !   So wtf ?

The mag field was an interesting one too .. I could not figure out why I was only getting 220 - 270 strength.. started trying all sorts of stuff , long story short was I had the short 90 degree mini lead plugged in so I could access it easily .. well due to it being 90 degree plug it meant that the lead had to go around the front of the pixhawk  and terminate towards the rear .. so it lay neatly under my dome, well after removing the extra little usb lead .. the mag Filed jumped up to 680 instantly .. Note: the USB lead was not powered it was just sitting there.. So the lead was affecting the mag field alot ! I will note i had already removed this lead when trying to calibrate the onboard compass so it was not the reason why the compass is not working ..  

Any thoughts ?? Anyone have similar issues with the on board compass going dead ?  At least you know now what to do the when you see the mag field too low ( remove any thing you have in front of it )  in my case a short mini usb lead.

Regards Reuben

So that looks like very bad offsets possibly caused by having metal near the compass.  The Pixhawk board itself causes quite large offsets on the internal compass which is why I'd recommend always using an external compass.

Re your work on a weed sprayer.  There is an undocumented SPRAYER feature in ArduCopter.  I've done a videoof the original project I did that prompted this development in case it's of interest.  Basically it allows controlling a pump and a sprayer depending upon pilot input and vehicle speed.

Hi Ravi, try first Motorsync with Pixhawk/Afro/motors.

might be useful to find out sync issue with your esc's.

Do you use ground of PWM signal connected ?

Ciao - Giuseppe

Thanks Randy for your swift reply as always .... I dont have any metal on the mount for the PH infact the only thing was near buy was the usb lead .. The end though was placed at the rear of the PH but the lead it self passed in front of the PH ... BUT it was flying fine .. I only noticed the Mag field was week ( since I  found out it was due to the usb lead which i have now removed ) but the internal compass refuses to calibrate only showing data on one axis .. Strange how it was fine for many flights tests then out of the blue no more Loiter .. works now with the external compass , but I would still like to know why the internal one is dead ??

Reuben,

    I don't think the compass is dead.  If you check the flight data screen's status tab and look for mx, my, mz I think you'll see that all three are updating.  The pic above showing only one part of the sphere being filled in is because of very large offsets I think.  There have been some changes in the mission planner recently to deal with large offsets so I think it must be related.

before i changed to the external compass I did a CLI compass test I saw that it was not outputting correctly when turning the frame  ? would this be similar to looking at the status tab ?

I also noticed that the Heading in the HUD was not moving .. when turning the copter it would move briefly then come back to roughly where is was before .. Mostly likely due to the accelerometers inertia ..

incidentally i have just built another machine and it has APM on board but that one too will not loiter ..takes off in any direction when Loiter is engaged .. compass calibration seemed to go well on that one .. perhaps this is all to do with MP .. but does not explain why all of a sudden on the PH the compass only works on one axis ? I know you say it high off sets .. but i have zero'd these and done erase reset but still no joy..

Should CRate look like first derivative from RelAlt on dataflash logs?

They both should be based on Acc + Baro, but it looks like Acc component for CRate has higher weight in 3.1.4 At least in my case.

As vibrations increase, CRate drops down into negative area, while RelAlt increases (see image). Is that normal?

(I know, I should eliminate vibrations first, but anyways, can CRate be negative, while RelAlt increases?)

Attachments:

Arseni,

     That's the classic symptom that shows up in the existing inertial nav when it's exposed to high vibration.  It's somewhat expected that the altitude and climb rate don't match because the complementary filter is trying to make sense of incompatible information from the accels and baro.  It is slightly odd that the climb rate always goes negative in these situations..I'm unsure whether it's an issue in the inertial nav library or an issue in the accelerometer hardware.

     The only way to resolve this on the APM2 is to cut down on the vibration in the frame or adjust the mounting of the flight controller.  With the Pixhawk it should be more resistent because it has dual accelerometers.

Well having disabled the compass 2 weeks ago, I don't have any wandering issues even in strong wind. So the question I have is why can't the APM be set to use the compass when first turned on to get a rough heading then use the gps from then on? It would certainly keep things simple!

That only works in manual flight modes.  If you try to use loiter or any auto modes you'll need the compass.

"why do we need the compass?" is a common question.  The short answer is that the gps tells you the direction of travel, not the direction the vehicle is facing so the moment the vehicle stops moving you'll start getting drift in the heading and copters spend a lot of time hovering.  In fact though, the EKF (Pixhawk only) can figure out the heading as long as the vehicle is moving.  The EKF is enabled in AC3.2 but it won't be the main attitude & position management system until AC3.3 most likely.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service