Developer

ArduCopter-3.1 released!

After months of testing AC3.1 is finally available in the Mission Planner and GitHub.

Warning #1: If the vehicle is left landed (but armed) while in AltHold or Loiter mode for more than a few seconds, the vehicle may suddenly jump into the air the moment the pilot raises the throttle above zero.  The reason is the baro altitude may fall while the vehicle is sitting on the ground.  In AC3.2 this bug is fixed because we reset the target before take-off.

Warning #2: Motors will spin (slowly) by default as soon as the copter is armed!  You can switch this feature off by setting the MOT_SPIN_ARMED parameter to zero.

Warning #3: if you see "Bad Gyro" on the HUD then you may have a blown 3.3V regulator.  See this thread for details.

Warning #4: if you use a sonar set the SONAR_GAIN parameter to 0.8 or lower

Warning #5: Trad Heli users should now connect their main rotor ESC to APM's RC8 output

Warning #6: Trad Heli BUG causes loss of collective control in ACRO mode if swash type set to flybarred (i.e. not flybarless).  Will be fixed in AC3.2.

 

The major improvements over AC3.0.1 are (full list here):

1. Pixhawk support (Tridge & PX4 development team)

2. Autotune of Roll and Pitch gains (Leonard/Randy)

3. Drift mode (Jason)

4. Improved Acro (Rob/Leonard) and new Sport mode (Leonard)

5. Arming, Take-off, Land in Loiter or AltHold

6. TradHeli improvements (Rob) including:

a) support for direct drive tail rotors

b) smoother ramp-up of main rotor

c) reduced collective for better control in stabilize mode (STAB_COL_MIN, STAB_COL_MAX params)

7. Support for SingleCopter (Bill King)

8. Performance improvements resolve AltHold troubles for Hexa & Octacopters

9. Safety Improvements:

a) GPS Glitch detection (Randy)

b) Motors spin when armed (Jonathan Challinger)

c) crash detector shuts off motors if copter flipped for 2secs

d) batt failsafe option to RTL instead of LAND, gps failsafe option to trigger AltHold instead of Land

e) more pre-arm checks of inertial nav speed,

10. Bug fixes:

a) optical flow working again (although performance is still not great because not integrated with inertial navigation)

b) ROI working (use DO_SET_ROI command)

 

How to upgrade:
Click on the MissionPlanner's Initial Setup >> Install Firmware screen.  The version numbers should appear as "ArduCopter-3.1", then click the appropriate frame icon and it should upgrade as per usual.

Special thanks to Marco and the many beta testers on the AC3.0.1 thread who put their copters at risk during the testing of this new version and uncovered many problems so that you don't have to!  Here are some of their videos: loiter in wind, patio sonar, autotune, autotune2, roi, beach, acro, vrbrain, tricopter, train spotting, radio failsafe, the tree, double loiter

 

If you haven't seen it recently, please check out the ArduCopter wiki.

 

Feel free to post comments below and we're going to use the new APM Forum for support issues so please post your support requests there.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have no problems with guided Mode.APM and Pixhawk works fine in 3.1.rc2. Follow me at 3.01 APM no problems. 3.1 not tried yet.

    http://youtu.be/sQrlqXQ5O8g

    greeting

    • I mean first time and change new position before go to old position only. It have swing.

      • I have tried this morning with Pixhawk no problems. Copter in Loiter new position on laptop, copter goes to the new location. waiting for new position.
        No problems

        greeting
        Rainer

  • Hi Randy,

        I will report to you about Bug with change to Guided mode. When i will change to Guided (Click Fly to here with Map on MP) my quad, It like jerky or over swing on the air. And sometime, I have change Position is before move to lasted point. It have break and almost a backflip. But, Today i have loiter so longtime is no have problem and after change to Guided mode is have jerky and backflip have crash. I very lucky not damage on my quad. 

    I can't sent my log. Because, I used Pixhawk my logs have big size about 12 MB.

    3692944235?profile=original

  • Hello,

    I have activated logging of motors, IMU and compass. In this picture when flying forward there is some unwanted roll and yaw.

    3692944320?profile=original

    Motors look good to me.

    3692944329?profile=original Thee gyro "sees" the yaw as you can see in the images (i hope gyro units is rad/s). Also the Acc notices the roll but it is not corrected

    3692944443?profile=originalI have no idea how to interpretate the compass values. Can this be due to bad compass calibration, compass mot or compass declination? Can I fly with a deactivated compass in stabilize?

    edit: this is a reply to this: http://diydrones.com/xn/detail/705844:Comment:1551039

    2014-02-06 16-54.log

  • I loaded up 3.1.1 10 days ago and while the Hex flew exactly as it did before in stabilised, I tried alt hold, loiter and they worked fine as well. I selected land and the descent was unusually high so I flipped back to stab and landed. I checked the full parameter list and it was as it was before, 38cm/s. I was flying out for work so I packed it away till I got back home spending a fair bit of time thinking why that had changed.

    I got the Hex out today and before flying I went into the full parameter list and refreshed the parameters and went for a fly and land was back to how it was before.

    I have no problems with differential temps of motors or ESC after 10 minutes of flight time.

    There maybe a message for others in here, as I also updated to version 1.2.93 of MP, maybe the 1's and 0's got a little bit fargled.

  • So i posted this elsewhere but no-one seems to have seen it... So i thought i would post here see if anyone can help

    Hi folks

    So i took the pixhawk out for a flight, everything working ok.

    Flying beautifully, attempted the auto tune but too much of a breeze to keep it in the one place.

    So i keep flying it, no problems, then out of the blue it just flips and crashes to the ground, luckily not from too high up.

    So i try again at low height, this time taking off then it flipping on me.

    Any ideas?

    2014-02-02 15-28.log

    2014-02-02 15-32.log

  • Has anyone seen the HUD show a slow drift nose down after arming?
    This is during bench testing on pixhawk with 3.1.2rc1(or whatever is the freshest). With roll 180 on the ahrs.
  • Hi Randy,

    Can you have a look into this log from the pixhawk.

    Was hovering for 1 minute and suddenly its flips over a run into the ground.

    I cant find a problem in this log, pixhawk with 3dr external gps/compass

    Posted it on the following link

    http://ardupilot.com/forum/viewtopic.php?f=25&t=5995

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @diyrobocars @circuitlaunch And here's the final showdown! Video courtesy of @chr1sa I think I was a little faste…
2 hours ago
DIY Robocars via Twitter
RT @DanielChiaJH: @a1k0n @armand_dpl @SmallpixelCar @diyrobocars @circuitlaunch I use @foxglovedev Foxglove Studio for my visualization nee…
2 hours ago
DIY Robocars via Twitter
2 hours ago
DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
Monday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
More…