ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Hi Randy,

          Sorry for the delay, since this post was in-between, I missed somehow, this is the reason of delay from my side.

          I did not measure my lipo voltage after the crash but I was happy that after the crash, the APM, GPS (gps mount broken but GPS ok), Telemetry, Lipo was safe from any physical damage. I charged the Lipo, it got charged well.

          I replaced two motors, one was fully damaged and other was partially. Uploaded RC5, did calibrations (Calibration of the attopilot current sensor as well as per the method, you indicated link).

          This time the voltage displayed by Mission planner without load was fully in agreement with that of Quanum and also voltage & Current display at 10Amp load was also in some agreement with the Quanum.

          Same Lipo I am using now, with APM2.6, AC3.2RC5, and I have absolutely not problem. I will soon try RC12 and share results.

  • Quick Question, (understanding the EKF/CH7/CH8 warning until RC12)

    I've been flying with consistenly good results on 3.2 RC10 on my 550 trad heli.

    Assuming I haven't modified any EKF params, what would happen if I upgrade to rc12, and then use ch7 to switch to ekf mode inflight?

    Do I need to change anything beside the ch7 function?  Is it better to enable it from the ground and takeoff?

    Anyone have any helpful experience?

  • Developer

    Please do not use the ch7/ch8 switch to invoke the EKF in-flight until AC3.2-rc12 goes out (should be tomorrow).

    Although people have been turning on/off the EKF using the ch7/ch8 switches for months, we've just found a bug in the switch-over code today that can cause insanely large velocity and position values to come out of the EKF for the first loop after the EKF is engaged.  Normally this insane value does not cause problems but we have one crash that we think has been caused by this.

    It probably only matters if you do it in-flight but it's probably safest to just not use the ch7/ch8 EKF switch until -rc12 goes out.

  • Alright... Flew my quad (same one that had an alt hold issue after fast accel it would go way up) It stopped doing that and left everything as I just re flashed the RC11 and did all the calibrations again.

    I noticed Loiter was not working well,

    I check my MAG 1 vs MAG 2

    Mag X 1 and 2 Tracks perfectly together

    Mag Y and Z are inverse? one is -200 the other would be 200... I am assuming this is a direction error. Can anyone tell me how many degrees to rotate based on that info?

    • Developer


      If you're using a 3DR external GPS and compass module then there should be no need to modify the orientation and I'd guess that the differences are caused by bad offsets (something metal near the compasses?).

      If it's not a 3DR GPS then yes, the orientation could be wrong.  The external compass wiki page has some advice on how to figure out the orientation.  i haven't tried this myself but it says the following:

      1. This Quick Setup Procedure will always work and allow you to set up your compass even if you use a non-3DR magnetometer.
      2. Set the (COMPASS_ORIENT) Yaw parameter so the direction your airframe is currently pointing agrees with the HUD in Mission Planner.
      3. Now turn your air frame right or left and if the compass correctly follows the direction it is pointed you are done.
      4. If the compass turned in the opposite direction of your airframe set (COMPASS_ORIENT) Roll to 180 (flips the compass over).
      5. If you need to set Roll to 180 (COMPASS_ORIENT) will also need to include the Yaw from B. above (Example: Yaw 180 Roll 180).
      • 3702670534?profile=originalRandy these are my offsets, should I check for this too? I'm using a NEO-6M GPS/Compass.

        BTW my pixhawk is inside my TBS Discovery

        • Developer


          So I guess the NEO-6M GPS/Compass is not from 3DR?  If it's non-3dr I really don't know what's it's orientation should be but the above procedure could be used to figure it out.  My guess is that if the manufacturer intended for it to be used with ArduCopter then they've made the orientation the same as the 3dr one but I really don't know.

  • Hi Randy,
    unfortunately today i was having another crash because of the flip issue in acro mode.
    This is the third of this kind.
    slowly it becomes more and more expensive. Therefore i've really hope we can find out the issue.

    Could you take a look to the attached log please ?

    This is what happened.
    i was doing speed and climb tests today. Also if done some slow and fast Roll's in acro mode, all went fine till the first Flip which ended in a big crash.

    i positioned the copter preparing it for a flip in acro mode. then after the flip i've realized that the copter is going to lose stabilisation, i've tried to stabilize it manually in acro mode but the copter didn't respond to any input at all.
     After i realized that i cannot stabilize it manually i've switched to stabilize mode and raised throttle, you see clearly in the log that the Throttle was completely maximized but the motors have not respond.
    the force of impact seems to  be about 5g.

    Until we have not found the source of this issue i'll go back to AC 3.1.5 and will wait until a solution is available for testing otherwise i think that i will not upgrade anymore.

  • Had three flights flights today: first one seemed totally fine. Last two ended in nasty crashes. 

    So at the start of my second flight, I rose up a bit and switched into Loiter and it started to slowly toilet bowl, and then it got worse and worse and worse. Hindsight being what it is, I should have put it into Stabilize, I tried RTL but that did nothing. I really had no control over it and it started moving faster and faster in a circular motion and eventually crashed very hard. Broke all props, gps mast and some other things got roughed up a bit. 

    So after taking it back home, fixing it up a bit, I replaced the gps mast and GPS (first flights had the m8, but after that I went back to the standard 3DR 6H gps).  It seemed like I fixed it up ok so I took it back out. Before I flew it, I calibrated everything again, mainly to account for the change in GPS. Took it up in the air and it seemed to fly fine. Put it in loiter, and it didn't move much other than some bobbing up and down (which it was doing previously anyway). So then I tried to switch on EKF (i have it setup on ch. 8) and as soon as I flipped it on, it absolutely DOVE straight into the ground. Never seen anything like that. EKF always worked fine before. Broke more props and another GPS mast.. yay.. 

    I have no clue what's going on, but these two crashes are the first two that I have had that weren't caused by obvious pilot error. They may have nothing to do 3.2 (I believe I'm running rc11), but I honestly don't know. I would love it if someone could check the logs and let me know what they find.

    Thanks in advance.



    • Re "So at the start of my second flight, I rose up a bit and switched into Loiter and it started to slowly toilet bowl, and then it got worse and worse and worse. Hindsight being what it is, I should have put it into Stabilize, I tried RTL but that did nothing. I really had no control over it and it started moving faster and faster in a circular motion and eventually crashed very hard. Broke all props, gps mast and some other things got roughed up a bit. "

      That sounds EXACTLY what happened to me except my quad was never found. It started to toilet bowl and I basically lost full input  control. I could effect it's flight somewhat but it would not fly in a straight line no matter what I did. I did switch to stabilize as a last ditch effort but by then it was so far away I could never establish orientation before it flew out of sight. I was flying with a M8gps. Im not flying with anything but a 3dr ublox until I know better. 

This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022