ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Solved, just push the update button in Mission Planner, then the PosHold mode came up.
  • Loaded up 3.2-rc6 on my Pixhawk today. Flew well even with no auto_tune done yet. Loiter was solid (now that I solved my compass setting issue), and RTL was fine like it was with the APM 2.6. 

    I let RTL land it three times and had no issues, repositioning on the decent worked fine.

    Have not looked at the log yet, but I have downloaded it.

    I'll do an auto_tune during the week if the weather is OK. Then try throwing it about harder.


  • Developer

    ArduCopter-3.2-rc6 is now available through the Mission Planner’s Beta Firmware link.  The changes can be seen in the Release Notes but they’re also copied below.

    ArduCopter 3.2-rc6 31-Aug-2014, Changes from 3.2-rc5:
    1) Spline twitch when passing through a waypoint largely resolved
    2) THR_DZ param added to allow user configuration of throttle deadzone during AltHold, Loiter, PosHold
    3) Landing check made more strict (climb rate must be -40~40cm/s for 1 full second)
    4) LAND_REPOSITION param default set to 1
    5) TradHeli with flybar passes through pilot inputs directly to swash when in ACRO mode
    6) Safety Items:
       a) EKF check disabled when using inertial nav (caused too many false positives)
       b) pre-arm check of internal vs external compass direction (must be within 45deg of each other)
    7) Bug Fixes:
       a) resolve NaN in angle targets when vehicle hits gimbal lock in ACRO mode
       b) resolve GPS driver buffer overflow that could lead to missed GPS messages on Pixhawk/PX4 boards
       c) resolve false "compass not calibrated" warnings on Pixhawk/PX4 caused by missing device id initialisation

    All feedback welcome.  In particular I’d like it if people could take-off and landings in AltHold, Loiter, PosHold modes.  The stricter landing check should be consistent with AC3.1.5 but if you’ve been flying with earlier AC3.2 release candidates you might find it more strict that you’d like.

    • Loaded 3.2-rc6 from 3.2-rc4.  Re-calibrated the compass when prompted.  I landed and took off in AltHold and PosHold a number of times with no issues.  I ran autotune to completion, landed and disarmed with autotune enabled, but when comparing parameters it didn't appear to change anything during the autotune.  It was already flying pretty solid though.  I hesitated to try SBUS2, opting to make sure rc6 was working for me.  I previously flew a .6 mile auto flight (farm land) with rc4 and had no issues.  DJI F450, DJI E300, Pixhawk, external 3DR GPS, & Futaba Tx/Rx.  Thank you for your work. 

    • Randy,

      I wanted to confirm landing and taking off in althold, poshold and loiter all works well. We are having 15 to 20mph winds with gusts up to 30mph and it did great considering. I had to recalibrate compass and accel after flashing rc6 from rc5. I could not get it to arm without doing so.

      • Developer

        George, Martin,

        Thanks for the reports.  I certainly hope after we fixed that init bug in the compass driver that this will be the last time you're forced to re-do the compass calibration.  By the way, MichaelO has dramatically reduced the strictness of the compass calibration in the next version of mission planner.  I'm able to calibrate now in about 300 point... i haven't tested whether the accuracy has been sacrificed at all but I suspect it'll be ok.

      • I had to recalibrate the compasses to get it to arm after rc6, but not the accel. 

    • I test rc6 and confirm, twitch, as the vehicle passes through each spline waypoint, is gone. Very smooth flight.

      • Developer

        ReM, thanks for the confirmation!

    • Developer

      I've found yestarday a problem with Simple/SuperSimple, relatively dangerous, tested with Pixhawk and external compass.
      If you are running continuous fast yaw rotations the "virtual nose" of the drone is moved approximately 45° compared to the initial position and in the opposite direction to the imparted yaw rotation, this makes Simple and SSimple unusable.
      This problem is never revealed normal use, where hardly turning the drone like a top, however be careful.

      For 3.2 release this thing definitely will be resolved.

This reply was deleted.