ArduIMU V3 output Error

Hi,

I just ordered the ArduIMU and when I try to view it from the arduino serial window it only works for 9 loop refreshes then it displays a line of random characters and then repeats. I believe it is a result of a serial timing error. Any suggestions?

Daniel

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Daniel

    Does the "random"  message look like the following ?

    I'm having the same issue and  seem to think that it is a string of bonary data being sent from the AP_GPS library to the GPS and being echoed to Serial monitir. 

    I'm using a Ublox 6 GPS with the Arduimu.  Perhaps you can post your "random"  characters ,  which I think is not random but some binary data,  as you see a repeatable pattern and the string, in ascii,   +KMLL003,0001,38400,0*26   which includes the BAUD of the GPS and what appears to be a checksum.

    Simon

    LAT:183347179,LON:-649220870,ALT:9,COG:160,SOG:0,FIX:1,SAT:5,
    LAT:183347139,LON:-649220859,ALT:8,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183347108,LON:-649220840,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183347057,LON:-649220790,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183347020,LON:-649220769,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183346993,LON:-649220752,ALT:10,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183346966,LON:-649220754,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183346934,LON:-649220767,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    LAT:183346918,LON:-649220760,ALT:9,COG:160,SOG:0,FIX:1,SAT:6,
    x<x<xxx<xÀøxàxÀxÀxÀøxàxÀxÀøøxÀx<ðøxx<ÿøxÀxøxxø`f3fÌÀfxÃ0à<àÀÀÀxÏàÀÀà<xüæÀÀ<À3ÃÏ30æàyáaó U(+KMLL003,0001,38400,0*26
    µb/@hP¬H*16©±Â5V±±ª©!cT#üµbÈÝhµbGµbIµbOµbgµb$*x<x<xxx<xÀøxÀxÀxàxÀøxÀxÀxÀøøxàx<ðøxx<ÿøxÀxøxxø0`f30fðÃ`à<àÀÀÀxÏàÀÀà<xüæÀÀ<àfxÃf<xx`ÿ
    U(+KMLL003,0001,38400,0*26
    µb/@hP,H*±v©1µ±±ª©!cT#üµbÈÝhµbGµbIµbOµbgµb$*x<x<xxx<xàøxÀxÀxÀxÀøxÀxÀxàøøxÀx<ðøxx<ÿøxÀxøxxø`f30fðÃ`à<à<ÀÀàxÏàÀàà<xüæÀà<À3ÃÏ30æyáaó ª+S)    ¦&KLL&NM,0*26
    µb/@hP,H*±v©±ÂµV±±ª©!cT#üµbÈÝhµbGµbIµbOµbgµb$*LAT:183347036,LON:-649220838,ALT:8,COG:160,SOG:0,FIX:1,SAT:4,
    LAT:183347071,LON:-649220860,ALT:8,COG:160,SOG:0,FIX:1,SAT:5,
    LAT:183347093,LON:-649220835,ALT:9,COG:160,SOG:0,FIX:1,SAT:5,

  • Did anyone get a solution for this, other than turning off all GPS Requests?

    I am getting the same output when using a ublox GPS and setting gps device to 4 for the ublox. This error goes away when using a mediatek GPS (but the mediatek does not produce any GPS output).

    Sometimes the GPS message comes through properly, and sometimes it is skipped many times, but almost always their is gibberish or binary about every 9th line using the ublox.

  • i need help how can i connect Ardu IMU to Arduino mega 

  • I just loaded v1.9.8 and noticed the same thing. Here's what I discovered. I am not using a GPS, so I set GPS_CONNECTION to 1 for programming pins figuring this would shut off GPS altogether. It does not. It still tries to initialize the GPS every second, thus causing a stream of seemingly random characters. The stream depends on the GPS_PROTOCOL selected.

    To change this behavior, I wrapped each call to GPS in arduimu.ino with if (GPS_CONNECTION == 0).

    I'm not sure if this is a "proper" solution since I just started looking at the code but it works for what I need.

  • I uploaded it with a sparkfun 5v ftdi basic. The test code from the website works but all other versions of the code produce weird readings.

    Sorry for the late reply, I was waiting for an email notification and then forgot about the thread.

  • What did you load it with?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…