ArduPilot Mega RC Output 1

So IK have determined after a days worth of testing that the RC output on my AP Mega is not working.  I have double and triple checked the soldering and connections and all looks fine.  I cannot figure out what else to do or check.  I suppose my question is what else can I do to troubleshoot this problem?  Has anyone else out there have had similiar problems with RC Output 1?  Is there any way to remap the AP Mega so that everything works off of one channel higher (ex. plug the inputs into 2-7 and outputs 2-7)?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have also lost an RC/MUX/Servo output.

    Mine happens to be #3 which is the rudder servo.

    The remaining three outputs function normally.

    I am puzzeled how this happened, last weak the system worked flawlessly. I tried to fly yesterday and there was no servo output.

    The APM is recognizing the input from RC receiver as indicated by the radio test in the CLI.

    The servo is fine.

    When the apm/oilpan are powered up the Multiplexer ( 74ls157d ) gets abnormally warm.

    With my DVM I determined that the ohm readings between the power rail and the servo signal outputs were all similar except output #3 had a much higher resistence value.

    My guess is that somehow the Multiplexer is shot.  My reasoning being the heat being generated and the Ohm readings. I already have four replacements Multiplexers coming from DigiKey.


  • Hi friend,


    I am having some problems like you, you can read my post hear and see if you have similar problems



    nobody has respond to my post


    I hope if I can help you in something



  • I also have this problem.

    CH1 not working.


    Another possibly unrelated problem i have might be due to my old analog TX RX

    I have problems with all my servos jittering. If I power off my transmitter they go nuts and they jitter so badly when I'm programming the APM that it broke one of my servo horns as the servo went past where it should.

  • I had a similar problem and nobody answered my posts on this. I lost all my RC outputs after an accidental short. I ended up giving up and ordering a new main board which is on it's way. I spent a lot of time tracing the problem without success.
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21