ArduPlane 3.1.1 not working proper on flying wing any body else facing problem as soon as switch on to fbwb or auto mode it nose dive and roll on one side.

Views: 2419

Reply to This

Replies to This Discussion

Usually a setup problem, many are using AP3.1.1 quite happily on a flying wing. Test on the ground with the aircraft level, If you switch to FBW_A (don't use FBW_B just yet) then the elevons should stay level and move in their correct directions when the aircraft is rolled or pitched. If not your setup is wrong.

I have checked the elevon on ground direction is ok also tested in FBW_A same issue could it be a hardware problem? on flying wing i am not using rudder channel from radio do i have to close yaw gains?

3.1.1 works fine for me on a wing, please post a log file.

Attached find log file

Attachments:

When you say you've checked direction, is that the direction it moves in response to you moving the tx sticks? or the direction the ap moves the elevon in response to you moving the wing up/down left/right?

I have checked both TX and APM moving it in pitch and roll.

And the control surfaces move the opposite way to the way you move the wing by hand in fbwa? ie manually point wing up elevon moves to push the nose down?

Do you have a .log file or just the .tlog file?

yes in right directions i had tested a previous version i cant remember with flawless auto takeoff and landing.  in which folder is only .log file?

Hi Ahmed,

Looking at your log it is clear your RC calibration is a long way off. When you are flying in manual the zero of your sticks is around 1600 for channel 2 and 1447 for channel 1. Those values need to be in RC2_TRIM and RC1_TRIM so that ardupilot knows when you want the plane to fly level. It also looks like your _MIN and _MAX values are wrong. So start by re-doing your RC calibration. I suspect you may have skipped that step. You may also like to read up on the TRIM_AUTO option (make sure you read the docs carefully to understand how it works).

You should also fly in FBWA or AUTOTUNE before any other mode. Your flight log shows most of the flight is manual, then you skip straight to auto. You do spend a couple of seconds in RTL and FBWB, but not enough to actually tell how it flies.

I'd also highly recommend you read up on AUTOTUNE mode. If you are already comfortable flying the plane in manual then try AUTOTUNE_LEVEL=7.

Cheers, Tridge

Are you using the Airspeed sensor. If yes, and it is "enabled" make sure it is reading airspeed, had this issue with my FX-79, found my airspeed sensor was not reading, and was enabled, and in every Auto mode, it thought it was stalling, so it dove to gain airspeed. Also, I just had a crash this saturday that involved "min airspeed" beign set FAR too low, my fault I know, but this created a situation where the airspeed was a bit too low, and turning from down wind to an up wind situation, the aircraft tip stalled into a irrcoverable spin dive. Out of curiousity, which airframe are you flying?

I am not using airspeed sensor and it is disabled min air speed is well above stall speed. Airframe is custom cnc cut 3 part flying wing 2M span will post photos later.
It is not a problem for configuration what I think it is not taking the altitude it seems it is trying to go to altitude below 200M were as I have kept the default altitude 200M and I also tried to give higher altitude but same behaviour what I assume the Eprom is not flashing write value and in one flight it worked ok also.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service