Auto Mode-Waypoint issue on 2.7.3 firmware, APM 2.5

I tried the AUTO mode on APM2.5 and load my Quad with firmware 2.7.3  and then created 6 points for a start.1st to 4th point it when well when it reached 5 point the copter slowly decend itself even though the altitude set was 10m. Forced me to switched to RTL  every time it reached the 5th point. Already erased and reinstall the firmware but the same thing happen again n again. I didnt assign any LAND command on the 5 point and the rest of the points. Please reply on how to solve this.Cheerios!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The issue is in Auto the last waypoint is ignored, so it can be anywhere, as it will not be executed.

    When I upload a new mission from MP I always read it back to be sure it was written OK, and erased the last mission.

    If you follow the link at the top of this window Arducopter/Arducopter Manual it will take you to the Code.Google pages. 

    Click the Issues tab and there will be a list of currently open issues.

  • Hello and thanks Mike for this information! What exactly the issue is? It have something to do with the number of waypoints or? If the workaround is to add another waypoint to the end of the mission, this must have exactly the same coordinates?

    I have the same configuration as Mie Must and I have tried last weekend a path with 8 waypoints. After loading the mission over USB I have tried short the AUTO mode and realize as the copter will turn in the next waypoint direction. I have canceled the mission to set and test the YAW ANGLE values (later realized as will be not accepted). Because the airfield was too busy, I have created another mission with another 8 waypoints, behind the airfield. The old mission cannot be erased (!?!) just overwritten (is that true?). So, on the new place with the new mission the quad has gonna crazy in Loiter and RTL mode too. With full throttle start ascending without limit. I have tried to erase the mission and check every settings but without success. Late evening I have loaded again the first mission and returned over the airfield. The Loiter and RTL works fine again from the first moment and after that in AUTO mode the quad has performed the complete mission with 8 waypoints two times without issues. I have no idea what was wrong but seems as he want only fly over the airfield...

    As soon as possible I will try to reproduce this issue again but I want to ask if somebody else has observed something like that. Also I asked on some other topics if still exist somewhere an official bug reporting topic from where we can inform us if an issue is already known or if not, than report it. Is really hard to search each topic to find answers.

    Thanks in advance.

  • This is a known bug in 2.7.3 to be fixed with the release of 2.7.4

    Just add another waypoint at the end, so waypoint 7 at the same place as waypoint 6 will fix the problem.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…