I'm currently having issues with getting the battery monitor to work properly on my Pixhawk 2 Cube from ProfiCNC. I thought that perhaps I had the wrong pins selected, but the Pixhawk 2 manual states they are PA2 for voltage and PA3 for current. 

My test has been to take 3 battery monitors, and wire both a Pixhawk 1 and pixhawk 2 plug to it. I would plug into the pixhawk 1 first, to confirm it works correctly, and then into the pix2, where I couldn't get it to read voltage. I have tried this with the original 3DR battery monitor/bec, the profiCNC battery monitor/bec, and an AttoPilot 180A, with a bench PSU supplying 5v. Using the same PSU I supplied 15V over the battery lines. Here is my setup.

As you can see, I flashed the latest X8 firmware onto the Pixhawk 1, and it reads the voltage just fine.

I did the same setup on the Pixhawk 2, and I the calculated voltage fluctuates all around, and does not respond to me adjusting the battery input voltage. 

I've even went as far as saving the params from the pixhawk 1, and loading them onto the pixhawk 2, but that did not help either. If anybody has any idea how to help me get a battery monitor working with the Pixhawk 2, it would be greatly appreciated.

Views: 1124

Reply to This

Replies to This Discussion

Set BATT_CURR_PIN correctly :)

Could you elaborate on this? The BATT_CURRENT_SENS is set to 3, as stated in the manual. Would an incorrect current sense pin also cause me to not read any voltages with the on the voltage sense pin(2)?

My bad. I did not mean _curr_pin
Also check that current and voltage pins on power module connectors are swapped correctly, Pixhawk2 has pin 3 and 4 swapped on the power module clickmate connectors.

Thanks, I was sure to account for that. I was able to verify that the Attopilot was connected correctly. I verified with a multimeter. Unfortunately, the problem still persists.

Andre K. said:

My bad. I did not mean _curr_pin
Also check that current and voltage pins on power module connectors are swapped correctly, Pixhawk2 has pin 3 and 4 swapped on the power module clickmate connectors.

Maybe it is a similar issue I found where in fact, after any change in mission planner in that current monitor window, you actually need to reboot the pixhawk board and reconnect mission planner to see the changes. Have you tried that ?

IIRC you need MP 1.3.48.3 or higher.

In that case, use Qgroundcontrol or APMPlanner2.
It's an incredible achievement to cock that up if mission planner in fact messed it up.
That would require some crazy logic to do so, as the data is sent over accordingly to mavlink specifications regardless of controller.

I finally got it working! rather than the pins listed in Mission Planner, I used the following:

BATT_VOLT_PIN: 3

BATT_CURR_PIN: 2

BATT2_VOLT_PIN: 14

BATT2_CURR_PIN:13

This pinout worked for the power1 and power2 ports, with the standard wiring of 5V, 5V, V, I, GND, GND.

Figured I'd post this here because the notes in mission planner seem to state 2,3 for V1, I1, and 13,12 for V2, I2.

I use to have the same problem with entering the rigth value. For pixhawk2 you need:

1. voltage and current

2. Other

3. Pixhawk2/cube

But in case it says 65  V or so you'll need to first set it on:

1. Voltage & current

2. 3DR power module

3, APM2.5+ 3DR power module

you'll see a lower value which you can't change. Now click on disconnect (still the Lipo attached)

Now you can set the correct voltage (like 16,2) use it with a comma and of course:

1. Voltage & current

2. Other

3. pixhawk2/cube

when you click on diconnect now you's get a BATT MULT error but just ignore it.

next time you connect you are good to go!

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service