Compass spins and behaves eratically

My compass has just started to spin in Mission Planner, and provide erratic readings, however if I go into CLI and run the compass test, it says that its holding its heading perfectly. I can't fly with the compass doing this, as it messes with the yaw and makes it yaw all over the place as it tries to correct its heading to the match the compass which is going all over the place. Sometimes it will work ok for a few minutes before the compass issue begins, and other times it will happen straight away.

I running MP 1.1.93 mav 1.0 and have an APM1 2560 with 2.6 epsilon. This is also occurring with 2.6 final. I am running 2.6 episolon since it seems there was a change between that and final which stopped the yaw from working correctly for me (on a tricopter). I have also tried going back to 2.5.4 and the compass still doesn't work properly. I do a CLI erase before changing any firmware, and even straight after a fresh firmware load, the compass won't track properly in MP. To begin with it will stay still, and as soon as I move the copter (by hand) the compass will move and then start to spin.

I've tried re-soldering the compass pins to make sure they weren't an issue, but if there was a connection problem, I am pretty sure that my CLI compass test wouldn't work.

Help! I am getting pretty desperate here.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Could be a faulty z gyro causing it.

    Check all your gyros in the raw sensor view.

  • I had the same problem and sent it in, the attitude was going all over the place as well. All they did was reload the firmware, I thought I had done that , but I guess not, works fine now.....Zdon
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25