Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Just loaded 3.3-rc11 on Iris+ with HK Pixhawk. Now my radio controller only partly works? Everything else works fine, I mean, telemetry over the USB radio hooked into MacBook gives back sensible data, and GPS, compasses, accelerometers working in APM.

    I did try changing the MavLink ID at one point, but I changed it back.

    When I turn on the RC, the Pixhawk gives the sad double beep, followed by the happy double beep. Flicking any of the channel switches causes a small beep, and I'm able to arm and disarm, but I get no data on my controller.

    • Developer


      Can you confirm which of the sounds you're hearing?  Is it the "Start up Failed" message?  Perhaps it's the "New IO board firmware found" but with two sad tones at the end?  If that's the case then the I/O board's firmware (the Pixhawk has two CPUs) hasn't been loaded for some reason.  If you have a safety switch you can try to force it to load by holding down the safety switch as the board is powered on.

      • The sound was like the "Failed To Arm" sound, followed by something like "New IO board firmware loaded successfully", except with only two notes, and in a major key.

        It's a moot point now though, because even though I've downgraded to 3.2.1, I'm still unable to connect completely. I can't connect over MacLink with the little USB transceiver, and get telemetry in APM, but my FrSky DJT radio only turns the receiver light green. If I'm in APM on Calibrate Radio, and I turn my transmitter on, all the calibration items clear, and none of them respond when I fiddle with the sticks or switches. Tried rebinding and all that of course.

        I wonder what the heck I did to make that happen?

      • When the transmitter was turned on, it was the same sound as when you're trying to arm but the safety switch hasn't been pushed, followed by two higher tones going up when the transmitter completes its startup.

        However, its worse now. I tried rebinding the receiver and transmitter, and now I get almost nothing. This is an Iris+ with FS-TH9X transmitter and a D4R-II receiver. I took it through rebinding, got the red and green lights going on the D4R-II first, then on the FS-TH9X, then powered down both and restarted. Now the receiver gets a green light when the transmitter is turned on, but the transmitter stays with red and green. There's no connection to the transmitter when I try the radio calibration screen in APM. However, when I turn on the Iris+, the transmitter makes a little beep.

        So there's some connection going on, but it's minimal. It's late now, tomorrow I'll try moving it back to 3.2.1 and see if that fixes things. For all I know it could be unrelated to 3.3. Connections from APM work fine, both through USB and through MavLink.

  • Hi all,

    Trying to load Rc11 (and RC10 for that matter) with APM Planner onto my pixhawk (non 3DR version) I haven't had any issues loading firmware in the past but now I can't get past the status showing "Requesting CoA" ...It won't load stable also. I tried QGroundControl and I was able to load firmware on using that. Unfortunately I had to download the source then do a custom load. I have Has anyone had any issues with this? Tips/advice?



  • Does anyone knows if the receiver failsafe option will be back on AC 3.3 version?

    • What specifically are you referring to regarding receiver failsafe? I have personally tested RC failsafe on 3.3 rc 10 by turning off the tx, resulting in a correct RTL. Simply assumes the tx/rx failsafe is configured for no pulses, then that the failsafe throttle setting is somewhere in between the normal idle and the absolute minimum when the tx is turned off.

      • As per wiki instructions( ) there is 3 ways that you can set radio failsafe.

        Low-Throttle method

        No signal method

        Receiver method

        I'm referring to the 3 option. It was working on AC3.1.5 and is not working on 3.2.1

        Same thing for the failsafe on AUX channels 1 to 6, on ac3.1.5 I set my camera to be pointing to a specific position in case of an loss of signal in my receiver and it's not working anymore with 3.2.1.

        I have done a detailed report of the problem here about one month ago. For me it was very useful and I'm said that it's not working anymore. I didn't see any info in the AC3.2.1 release description saying that it would be disable and besides, receiver failsafe instructions are still in the wiki.

        Thanks for your reply.

        • I had problems with the receiver method in 3.1 and 3.2. Depending on where my mode switch was it would act differently. Doesn't make sense but that's what it did. No signal method is what I prefer because it will continue in RTL even if the RX regains signal. But why it worked for you in 3.1.5 but not 3.2.1 is a mystery. 

          • Thanks for your reply...

            I tried in 3 different pixhawk board, and in all of them receiver failsafe would work in ac3.1.5 but not in the ac3.2.1, so I understand that it was a firmware problem.

            Anyway, is there anyone that could confirm that the receiver failsafe method should be working in AC3.3?

            Thanks in advance.

This reply was deleted.