Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Great. Thanks.
  • I attempted to upload 3.3.2 coming from 3.3.1 and the upload completes fine.
    But when the "please wait for musical tones to finish before clicking ok" pops up I do not get any musical tones even after several minutes.

    The hawk board won't connect to mission planner or do a start up cycle when the battery is connected. The small lights flash, but the large led stays dark.

    I have tried using different USB cables and tried loading ardu plane also. Each time the up load completes but no musical tones.

    Using the latest MP

    So how do fix this?
    • Try first holding the safety switch down and powering up the hawk. If this fails backup your SDCard and format it Fat32 and then see if it doesn't completely the boot cycle. Try flashing back to 3.1.5 and connecting via console and do an setup/erase and setup/rest

  • I am having 'Compass variance error' since upgrade to 3.3.2. I was flying beta versions previously with no issue. The problem seems to be worsening as well.


    1000mm hexacopter, New Pixhawk (imu failure on previous one), CSG Shop M8N XL (primary GPS), Generic Neo-M7N, RFD900, 1.2 video tx, Frsky X8R rx, 900 mhz gps dog tracker

    6s dual 8000mah batteries

    AUW ~6kg

    It gives no indication of failure at startup, but once I get off the ground in stabilize it will randomly do a roll pitch and then maybe give me a compass variance error and then do a large pitch or roll twitch. I can switch into alt. hold and pos. hold and it will do the same thing. The twitches are getting worse with each flight it seems. I tried recalibrating the compass with no improvement and I just tried switching to the 2nd gps compass (did calibration) and the same results. I'm not very experienced at log review and hope someone can help.

    In this log I took off, saw a twitch, switched into alt. hold, pretty sure I heard the computer say 'compass variance error and then it pitched back and left pretty hard. I recovered and land ASAP.

    TIA for help!

    2015-12-05 15-45-07.bin

    • I found the issue but don't understand why. It is the Garmin Astro dog tracker and the 1.2 GHz video transmitter interacting. I was mistaken, the dog tracker is actually transmitting in the 151-154 MHz range. With the video transmitter and the dog tracker off I see no issues, same with the video tx off and dog tracker on - no problems. Both on and it twitches, sometimes severely. I believe the current drop is just a response to this and we see it go to 0 because I am only monitoring one of two battery inputs.

      I tried moving the dog tracker all over the copter and it didn't help. I'm not really sure why this is happening at such different frequencies. Would love to hear any theories.  

    • I only notice that your current had fairly periodic spikes to 0. Seems like periodic ESC glitch. Check your CURR pllot.

      Have no idea for the reason.

      • Thanks for taking a look at the log! It does seem there is a power issue. I have a dual battery setup and I'm now wondering if one battery is loosing connection? They have separate power leads to the distro board and I only have one battery being monitored by diy power module. I have seen the compass variance error happen randomly with it just sitting on the ground not armed but I guess this could still be the issue. Guess that is where I will start looking.

        Thanks again. Open to any other recommendations.

        • I would suggest disabling the internal compass as it doesn't use it anyway even if the external fails. FYI it may or may not have anything to do with 3.3. I have had to do the compass calibration and then the compass mot a couple times before I stopped getting that error even with 3.2. Did you re-do the compass calibration when you went to 3.3? It might juts be finicky like mine [ and many of them ] and unrelated to 3.3. But if your certain the external is fine might want to just disable the internal and issue solved. 

          • I will give this a try but the current drops are still bothering me. What is strange is that the voltage doesn't really change, only the current dips. Also, compass 1 mag X and Y clearly show a deviation coincident with a current drop but compass 2 (pixhawk internal correct?) shows no deviation. 

            I have redone compass calibration and compass mot with no difference on both external compasses.

            I've attached a screenshot that clearly shows the above and I have attached another log showing a longer flight with greater issues. This log is from the csgshop M8N XL, so this behavior is present with two different external compasses.

            2015-12-02 13-48-59.bin

            Screenshot (3).png

          • +1

This reply was deleted.