I'm flying a DJI Flamewheel 550 with a APM 2.0, it's flying very nice. and using the DJI esc's and engines.

Sometimes in flight one engine is quitting the job. Only for half a second and then back to work.

Just enough time to recover :) The hardware seems ok, i checked the connections of the esc and the motor connections .. Is it possible thats it a software issue? 

The problem occurs sometimes in hover and also when flying a bit rough ...

Views: 2987

Reply to This

Replies to This Discussion

I am observing this also. And it does not happen all the time, nor every flight, but usually after 5 or 6 minutes of hovering it will sort of 'twitch' a motor, and not always the same one.

All connections are good, plenty of battery, JDrones Hexa prebuilt.

How does your wiring hold up when the quad is flying? Do the connectors get hot from delievering

a lot of current ?  Maybe the female side of the connector is expanding faster than the male side resulting 

in a temporary open circuit ?

Another possibility is your ESC is underrated for your motor so your ESC is getting hot ?

During hover you use a lot of power,  rough flight.. more power. Do you have an ottopilot board? Check the forums if you don't.  I suggest installing and enabling that.  I have my quad set to autoland if the battery is low.

Mike what size battery and motors are you using ?    My  2800mah lipo is only good for 5 minutes of stable flight.

Any longer than that and the battery is at 45% or so.. that's when you will observe the "twitch".  I programmed my quad

to end flight when the battery is at 46%.    I'm using the ottopilot board to monitor power and voltage.

Once I can land gracefully with a heavy load I will install my 6000ma battery :) I have it.. it arrived from hobbyking, but that bad boy is almost twice as heavy as my 2800ma bat.  I don't want to land hard with that weight.

If your battery is running low, you are going to get twitchy motors.   That happens with any servio control circuit. You need to monitor power and when the power is at the low end of stable flight then auto land.

We are running a pre built and test flown JDrones Hexa with 13Ah of battery on board.

The motors are pretty warm and ESC's only slightly warm after a flight. No connectors in circuit to the motors, all soldered.

The only connector is the battery and if that had a bad connection I would see a brown out of the system.

This motor twitching is a regular but very random thing and only appeared after the 2.7 update.

Max current on our setup is 32Amps at WOT, so the battery and ESC's aren't even trying hard.

Even though I have managed to tune a very solid Stabilise, I have issues with the other settings, but this motor pulsing off is very recognisable. It gives you a WTF moment, it IS that recognisable and random.

i checked all connections, but today it was a different engine, i will try to downgrade the firmware ..

see if that helps ..


     We have been getting some reports of twitching/pulsing so it could be software.

     If you're going to be running 2.7.1 could you turn on logging of the motors output to the dataflash?  You can do this by going into the CLI, logs, enable motors.  Then post the logs here.  ..and/or a video of the problem would be great because we're having troubles reproducing anything.

     Does it only happen when you're in an altitude hold mode or stabilize mode?

hee Randy,

it happens in stabilize mode, altitude hold off .. 

i will turn the logs on and shoot a movie today.

i tried to fly in my small 'garden' with the twitching engine's :) it's a short flight :) 

yesterday it was engine number 1 who had the hiccups, today it's engine number six i believe ...

the log file is here


the movie 



     Those logs were very helpful, thanks.  It looks to me like a radio issue.  The APM thinks that the pilot is inputting some very short but extreme inputs.  Could you try moving your receiver away from any other electronics?  I don't see any telemetry on there but xbees are notorious for causing interference so if you have one of those could you remove it and see if the problem goes away?


wow, the 40 degrees input was not mine :)

i tried to set the receiver away from the electronics, problem still exists ...

It could be a number of things..I would say..process of elimination is in order...so try removing one thing from the system at a time and see if the problem goes away...or start from the other direction by removing everything and then adding things back one at a time.

So the most basic test would be to try it with the APM2 powered from the USB port (i.e. remove the lipo) with nothing else but the rx attached.  Disarm the motors and give some throttle..of course nothing will happen but the APM2 itself doesn't know that so in the logs you should be able to see if the Roll In and Pitch In still have spikes.  I'll be they won't.

Next add only the ESCs that's providing power, connect with the lipo and test again checking those same two values in the logs (Roll In and Pitch In)...

..etc, etc until the cause starts to appear.

Are you using a Turnigy radio?

i'm using an DX6i, i tried to connect a different receiver (orange)

moved away all the cables, put it 10cm above everything ..

hooked up only the necessary channels,  still the same ..

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service