f450 unflyable

Hi, ive read and read, and followed instructions on these problems, but im still getting no where

im using a dji f450 with stock esc's and motors, 10" props, 4400 3c lipo turnigy 9x radio.

i had the naza system on this quad when i got it , flew fantastic in all modes but found it limited, so decided to try what looks a fantastic system apm 2,5.

I can just manage to fly the quad in very calm weather in stabilise mode, but when i switch to any gps modes its unflyable like its hanging from a piece of string on a windy day all over the place like a pendulem effect.

Ive balanced the props, used ear plugs as a cushoning for the apm. but im still not able to fly this thing anywhere near what i see on videos.

im using the latest firmware and mission planner

could anyone help me out please. i have some logs

thanks in advance

2013-04-11 10-39-36.rlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • ahh yes and the controller is on the bottom lvl with good damping, ive only just moved it there btw, it was on the top

  • oh and yes i wait for gps lock before i move

  • fw 2.9.1b

    gps is Ublox NEO-6M GPS v2

    P stab are 4.000 at the min but ive been all over with them

    compass offsets i dont know

    rx/tx is a rmilec uhf

    compass i dont know

  • This was one of the first setup I ran, you have to tune it.  What's your rate KP at?

  • Hi,

    I will follow your post... I have the same DJI f450 and I want to fly missions so I'm also looking at the APM 2.5.  I've been reading this forum for days and watching too many videos and I'm still not convinced (always some issues).


This reply was deleted.