First 3.1 Quad Build - Pitch Issues

I can not seem to understand what is happening here and I thought I would reach out for some assistance. 

After flying in stabilization mode for about 5-15 seconds the quad will slowly start to pitch harder and harder to the aft of quad. I fight it with the RC stick controls but eventually the pitch compensation is not enough and I have to land, it happens quick, I haven't had a flight last more than 1min. It is almost like the craft if trying to compensate for something and is slowly learning to apply more pitch to the aft of the craft.

After landing, power cycling, then taking off again the craft works for a minute then starts to pitch aft.

I am running the latest stable 3.1 firmware and Mission Planner. I have done a compass and accel calibration, Mission Planner indicates proper axis control when I move the craft while plugged into USB. 

Prior to flashing the firmware I did an erase, reset, and radio command to start fresh.

What am I missing? I am going to try a telemetry flight and record the details to post.

PS. I do not have anything covering the barometer right night now, but I didn't think this was an issue unless I was trying to do Alt. Hold.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Wanted to update this thread just so everyone knows what my issue was.

    1) I installed the CN06 Plus by RCTimer which isolated the FCU for vibration and moved the FCU further from the ESCs

    2) This also installed an external magnetometer

    Once configured the quad flies like a dream. I have flow 2.x before but wow 3.x is amazing! The ability to hold position is better than any of the platforms I have seen.

  • Okay, I have tried searching on this and came up with no results. This is my 3rd quad build and the only one I directly hardwired the ESCs to the the batteries. There is no power distribution PCB on this quad, like I have on my other two. Instead I just wired everything together and it sits in a circular arrangement about 1.5" under the FCU, have I made a grave error in how I have set it up? Also, I did read that this wasn't the greatest idea, but I have the ESC sitting on the end of the arms adjacent and beneath the motor, meaning the power runs from the center of the quad all the way out each arm. I will take some pics to show.

    I am going to attempt running compassmot and see what happens. I do notice that it happens in specific areas more frequently.

    I have two major fly areas and one gives me the error 10% of the time while since I installed the current/volt sensor, the other does it 80% of the time, I basically reset it move it, try again. I also notice that the position of the vehicle moves erratically at times on the MP even when outdoors and sitting on the ground (allowed to rest for 5 min before attempting anything). I also got the tilt issue the other day and when I looked on the MP it was hard tilted just sitting level when doing a "Manual level" it did not move, not until I power cycled did it reset to level.

  • This looks very similar to an issue I am having with my quad.  I cannot get it to lift off, it tries to flip on takeoff.  Have checked the usual suspects, motor rotation, props and motor positions and TX trim.  I have noticed with the APM plugged in by USB it is fairly stable when horizontal but add a bit of roll and the pitch and yaw start moving all over the place.  I ran a test with no main battery attached just to get the log, therefore no motors running.  I started horizontal when I armed then rolled it to about 65° and left it sat on it's arms.  Watching the readouts the ax, ay, az... through to mz and magfield all stayed fairly static but the pitch is going up and down, yaw is going left and right. 

    Looking at the log there is almost a sinusoidal waveform for each of pitch, roll and yaw, although the roll wave is less pronounced.

    In my case during takeoff the board seems to detect excessive pitch which is increasing, the board tries to compensate by increasing the motor speed on the opposite side.  In reality there isn't any pitch until the board tries to compensate which flips the thing.

    I've now got the board off the quad to make sure it's not an EMF issue but it's behaving exactly the same.  Running 3.1 stable at the moment.  Didn't have any problems with 3.1RC7 and updated to stable after a crash and re-build, I've not been able to get a stable flight since I updated.

    2014-01-13 19-55 11.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692920395?profile=original
  • I am running a one year old APM 2.5 with the internal compass. I seem to have resolved the tilting, not exactly sure what did it but now since I am using Andropilot for telemetry I have been getting occasional "check mag field" errors that preventing arming. Resetting it usually fixes the issue but I wonder if that is what is causing my problems. I think maybe an external compass may be in my future. Thought?

  • Okay I have done the following

    - Added some vibration dampening to the APM 2.5 board (has double sided 3m tape on the 4 corners 3 pieces thick)

    - Balanced Props (I did notice a vibration reduction upon takeoff)

    - Secured battery better (just in case it was throwing CoG by shifting)

    - Updated firmware to 3.1 (again)

    - Executed "reset" command

    - Ran setup wizard and followed through

    - Board is at 90deg YAW orientation, so I changed that, wrote config, restarted APM

    - Ran compass & accel a second time

    Upon flying this time it pitched forward instead of aft. It is so strange because it starts off so little and within 10 seconds it becomes too difficult to control. If I land, disarm, arm, then give a little throttle it tries to flip the quad forward over back. If I power cycle then it works fine for a few seconds then reverts. 

    Is there anything in the telemetry log I can be looking for?

  • T3
    Try resetting everything again.
  • Bad vibrations, balance props, use some vibration damping of APM
This reply was deleted.

Activity

DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
15 hours ago
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Saturday
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: Ran my car in the park, with single camera and @sparkfun IMU. #TensorRT on @NVIDIAEmbedded Jetson Xavier. Lanenet one fr…
Jun 24
More…