-Pls Help- Pixhawk dead just before his birthday?

Hi everyone, 

I need your help please, I'm afraid my Pixhawk is dying (which would be a shame since it's not even 1 year old). It's doing this:

Pixhawk anniversary from mterzian on Vimeo.

- I powered my Pixhawk for a flight today and couldn't start it. The main LED (I/O) is not blinking at all any more.  

- I tried to reboot several times with no luck.

- I tried to connect to APM planner via 3DR radio and the buzzer was making a very strange sound (see/hear video)

- I tried to connect via USB to reinstall arducopter but it could'nt connect to APM Planner anymore. I got an error message: "pixhawk error opening port no such file or directory"

- I tried the reset buttons on the side of the Pixhawk - nothing

- I reformatted the SD card - nothing 

WIthout the 3DR radio plugged, all I can hear is the ESCs beeping.

With the 3DR radio plugged, the buzzer is screaming.

Everything was working perfectly last night when I reconfigured the RC and loaded the auto mission.

I didn't change anything, nothing happened.

Please can anyone help me understand what is going on?

Thank you!

Mathieu

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Does the fault regulator destroy any other part or is it possible to desolder it and use external supply?

    Regards /Jörgen

  • I am having the exact same issue with the HKPilot32 from Hobby King.  I am not sure if it is considered a Pixhawk clone or just another PX4 implementation but I am having the very same issue.  The board is about 2 weeks old.  I noticed the other day that when I powered it through the power module it was experiencing this issue but when I powered it with the USB it worked fine.  Then, the USB stopped working as well.  I also noticed that the back of the board gets very hot after a couple of minutes connected to the USB.  I have an RMA request submitted to Hobby King hoping that they will replace it.

    Photo Feb 08, 8 00 47 AM.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3701931746?profile=original
    • Sorry to read that Shawn,

      Hope you'll get a replacement board soon.
      But get prepared to spend time chatting with HK support.
      I lost a lot of time with HK (for a lost package) but eventually got a solution offered.
      Good luck!
      And in the meantime you can do like me: install a naze32 or CC3D in lieu of the Pixhawk ;)

      Cheers,
      Mathieu
      • How do you like the Naze32?  I was thinking about that one before I bought the HKPilot32.  Seems like a capable board minus the autopilot. 

        • I like it a lot.
          I have the acro version (the same I use on my QAV250).
          The acro naze32 doesn't have the barometer, nor the compass (compared to the full naze32).
          So it's either manual mode (rate) or self-leveled ;-)
          But it's small, simple and fun!
          • Great!  I ordered one yesterday, it will be here tomorrow.  I went with the full version.  I figured it was closest to the HKPilot32 and if I ever get it back then this might be a nice backup flight controller.  This is my first build so a backup might not be a bad thing...

            Thanks!

  • I finally found the reason of failure of my cloned Pixhawk. Even cloners claim that they are selling perfect clones of open source hardware, they don't. 

    This is layout of offcial 2.4.5 version from https://github.com/PX4/Hardware . Notice main 3.3V switching regulator MIC5332 in 8-pin "MLF-8-PAD" package.3701916961?profile=original

    But look what I have on my board:

    3701917152?profile=originalApparently it is not a 8-pin device but something in 6-pin SOT-363 package! There is even no label on it! I'm guessing it could be some cheap 'alternative' or even vorse linear regulator which produces a lot of heat... I don't know if this replacement is used in all clones as this is the first Pixhawk I've had in my hands.

    My Pixhawk is already on the way back to China and my reseller promissed to send me a new "2.4.6" version as a replacement. I'm sure that before I power it, I will check the board layout and used parts.

    • Have just discovered this also Ivan, you are correct!  Some Googling led me here...

      I have 2  Pixhawks from China, one lasted seconds, the other, a few minutes.

      (Cloned versions from Alixpress. ver 2.4.5)

      Both U603 & U1002 have been replaced with some 6-pin linear regulator, not capable of supplying enough power.

      They should be Micrel MIC5332, 3.3-volt dual output, low-drop-out linear regulators. (not switcher's)

      U603 supplies power to (1) FMU & (2) Sensors, U1002 supplies power to (1) Spektrum & (2) I/O

      FMU power supply measures 0.3-volt (should be 3.3volt) U603 is too hot to touch... (bad)

      U603 regulator chip appears to still be working, just not able to supply enough power.

      I will look at replacing FMU regulator with something more heavy duty & see what happens.

      Will let you know the outcome... I really would much rather be flying my Quad...

      PS: Opened a dispute with Aliexpress, they have agreed to a full Pixhawk refund & keep faulty units... :)

      http://youtu.be/Ewj71yqcAMw

    • Hello Ivan,

      Little update: I tried to reload the firmware from the SD card.

      Powered the PIxhawk on while pushing the safety switch... nothing.

      This time I'm really done with it.

      Regarding the component on the board, here is a picture I took.

      It reads reads WSS 326 on it but I couldn't see no pins.

      3702542807?profile=originalCheers and good luck! 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
Monday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
More…