Help with loiter

hi guys

I have been out to test gps loiter for the first time, I waited until the gps module showed a lock , flew around for a few minutes without testing loiter,

landed, made another flight and at about 5 meters altitude i turned the loiter on to see what happens,

all that happened is that the cuad stopped responding and just softly landed, the landing infact was almost perfect, it slowly goes down to about 10cm and bounces a bit and thats about it, i turned off loiter, dropped the throttle and well , at least it was a nice landing,

I have made four tests, at 1m 3m 5m maybe 7m, i dont like flying higher for now, all of the tests have the same result, the cuad lands,

any ideas? (I have checked that its set for loiter not landing)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hi m00se I have the same problem did you fined a fix thanks jamie

  • Hey all!

    I have had a couple similar problems where the copter in loiter, alt hold, and auto where I will have been flying fine and suddenly the copter starts to descend slowly. Twice this has happened in auto where I was flying the same mission as previously and on the second or third run it starts to descend between way points. (no wind to cause any issues)

    My alt was set for 10m each time.

    However I was not as lucky and two crashes didn't come down nicely as yours (hit hip level grass in the field), but only broke an arm and a cable - so all good there.

    For the most part this works as intended however about 1 out of every 15 flights I have observed similar behavior, however min never stops until it hits the ground and then usually bounces up and flips over.

    (As a side note I could use some help tuning auto landing as it seems to land to hard causing flip over or tipping - if anyone has any advice?)


    APM 2.0 + case + dome crash cover

    arducopter 2.8.1


  • I have an APM 2.5 and since the case is still not available I ended up mounting it naked. Initially had the same behaviour until I covered up the barometer as per a post I found on here. In my case as soon as I tried alt hold it slowly descended.
  • Try it with sonar disabled. I have seen a lot of weird behavior with loiter and alt hold with sonar.
  • I've also had this happen several times now, using apm 2.5 + 3dr quad w/ ublox and sonar.

    Today when I tried loiter it worked much better - it wandered around for a good minute or so but did yo-yo up and down quite a bit.  I set loiter at ~ 10m it probably went as high as 20m and as low as 2m at about the minute mark it made a slow descent and touched down... like the original post a perfect landing. Battery was fine.

    One thing I did differently than my first loiter attempts is make sure the Advanced Param -> gpm_enabled setting was =1 it was disabled during my first loiter flights...  Not sure if that matters... Also, I know distortion and interference with sensor placement can cause this type of behavior but I haven't begun to test that yet.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25