Hexacopter Won't Take Off - No THR_MAX Setting in MP

I finished building my hexacopter and on my test flight it wouldn't take off. It was right at the cusp of flight, but wouldn't get completely off the ground. I've searched around the web and everyone mentions checking THR_MAX parameter in MP. So, I've checked there and no THR_MAX parameter is listed in any of the sections.

I've attached a screenshot of the full parameter tree drilled down into the THR section and you can see there is no THR_MAX setting.

Since I'm still fairly new and this is my first DIY, I assume I did something wrong in the setup to cause this setting to be missing, but I used the wizard with Hexacopter in X configuration and did all the calibrations (minus the ESC calibration because I'm using DJI ESC/motors). Is the setting possibly missing because I didn't do the ESC calibration, or is it something else I messed up/overlooked?

no_thr_max.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Very old thread I should have responded to once I found a fix. I simply switched from using MP to using APM and the initial configuration worked right away. I couldn't begin to tell you why MP didn't work after numerous times following the directions, but once I tried using APM instead of MP it worked immediately. Hope that helps.
  • Hi Brad, If you haven't messed with the THR_MAX value then leave it alone for now.

    Aside from the prop size and the fact your ESCs are from DJI you haven't given us much info. so we're kind of working in the dark (knowing your all-up weight, the size of the motors, battery size, etc. are all important.)  That said, there are any number of possibilities as to why your copter won't lift off so this will be a process of elimination.  To begin you'll need to verify the following:

    • Each motor is connected to the correct channel (verify via the Mission Planner motor test) 
    • Each motor is rotating in the correct direction
    • Props are mounted face-up and correctly oriented
    • Transmitter calibration has been successfully completed 
    • Accelerometer/gyro calibration has been successfully completed 
    • Battery is fully charged and the correct capacity for your setup
    • ESCs are in sync

    Now would also be an ideal time to thoroughly go through the Arducopter documentation, especially the checklists on these pages:

    http://ardupilot.org/copter/docs/configuring-hardware.html

    http://ardupilot.org/copter/docs/flying-arducopter.html

    Hope that helps!

    Mandatory Hardware Configuration — Copter documentation
  • Did you solve your problem I got the same problem

  • Bump, hoping someone sees this. 3dr says pixhawk is supported. Can I call them somewhere for help on this? All their links for support point here. Don't mean to bug yall, just wanna get this figured out, since everyone else seems to have a THR_MAX. Should I drop firmware to 3.2?
  • many times this because you either have the motors wired wrong or the props on wrong.

    Starting front left the motor should spin to the right and the prop should be a "R" prop. then going clockwise the next motor should be spinning left with a non "R" prop and then R and then L ect.

    also make sure your props have the lettering on the top.

    Next issue is the wiring, Again starting with the front left motor it should go to the pin labeled 3 on the hawk. and again going clockwise around it should be

    3.5.1.4.6.2

     

    • Thanks for the reply. I have confirmed using your numbers and the diagrams here that I have the wiring done correctly: http://copter.ardupilot.com/wiki/connect-escs-and-motors/#hexa_octo_y6

      I am using DJI 9450 props that can only screw on one way. They're labeled 9450cw on black tops which I put on the CW motor. The silver tops are labeled just 9450 and I put those on the CCW motors. The CW/CCW motors and props align with the aforementioned diagram.

      The only remaining thing I can find to check is the THR_MAX parameter, which is missing from Mission Planner for me, as shown in the attached screenshot in the original post. 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
yesterday
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…