Hi all,

I have problem with configurations of the switches:
http://pixhawk.org/users/system_modes

In mission Planner:

Now only one switch work, everything is calibrated(all switches).

So with graupner mx-20 and gr-24, how to configure PIxhawk flight modes?

I read something for switch 5, but I don't understand nothing.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi again,

    now I have problem with the channels:

    The RC is in airplane mode, and stick mode 1.

    The controls are:

    - the left side of the RC are the throttle and yall;

    - the right side are the roll and pitch.

    The problem are the roll and pitch - THE CHANNELS ARE REVERSED.

    - When I put forward i go to right, when i pull back, go to left. :(

    What can I do?

    • RTFM, then reverse the channels. :) 

      You should try to open the manual, the radio offers many nice features you'll never discover unless you spend some time with it.

      • Hi,

        I am writing because I couldn't find them.

        There is a section in the manual:

        -Joystick setting:

        Detail program description - Joystick setting.

        And I am not sure, after I read the manual can I use it for reverse the channels?

        -Another option that i see is the Wing mixers;

        I will test today, if any other idea you have, you could write.

        Thanks, have a good day.

        • Under "servo adjustment"   - change the arrow direction to invert.  :)

          • Hi,

            This is only if the channel is reverse. :)

            Maybe there is some misunderstanding:

            - when it has to be pitch it act like roll. This was the problem.

            And yesterday I made it, it is easy to change them from "Advance list parameters". You can assign the channels manually(I forgot exactly which parameters I changed), but it's very easy, there is description in the right for this.

            To reverse one channel you can set again manually at:

            chNUMBER_REV        -1

            My new settings for PID are:

            "P" for  roll and pitch are 0,30,  it's react very fast.

            "D" and "I" are 0.0000

            So now it works perfect.

            But now I have another problem:
            - at my transmitter, I am almost at the middle of the sticks and the copter react like I am at the end.

            So from Pixhawk is there a option to make it work with all way of the sticks?

             

            • Maybe is normal in stabilize mode to be so aggressive.

  • sorry : "failsafe"

    When the receiver loses connection.

    • that's easy if you use with PWM , and even easier with PPM connection - easily set up in mission planner or APM planner.

      I suggest you check out documentation on ardupilot.com

      • Thank you,

        All is good now, but I have problems with config of PID..maybe.

        new discussion

  • That description seems to use 3 switches, to get 6 modes. - it also seems to use 3 of your precious 12channels. a mess. :)

    My way, is to mix CTRL9 + SW8 directly in MX-20 , then send output in one channel.
    If you understand my notes /(I expect you to do) :) - and do it right, there's no adjusting or tuning - all 6 modes will be hit perfectly within PWM limits.


    Input5 Ctrl9 (Ct9)
    Input10 Sw8 (8)

    Servo adjustment
    S5 travel 65% 59%
    S10 travel 70% 85%

    Free Mixers
    fr10->to5
    symmetric +20% +20%

    ch5= main mixed output


    Enjoy :)
This reply was deleted.

Activity

Derrick Davies liked lisa TDrones's profile
yesterday
xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…