Can not get my artificial horizon to level in the Mission Planner anymore.

I have carried out the "Accelerometer Calibration" in the "Configuration>ArduCopter Level" section of Mission Planner and no joy.

Then I did the in-flight trim as per and still no joy.

The artificial horizon is about 15-20 degrees off level and I have to compensate quite a bit when taking off and flying.

I am using APM2.5 in Mission Planner v1.2.35 mav 1.0

I will admit I haven't been paying much attention to the updates and the planner does appear to have had some changes since I last flew a couple of months ago. I used to be able to level in the field by holding the throttle down and to the left for roughly 15 seconds from memory. But no more it seems...

What have I missed?


Views: 305

Reply to This

Replies to This Discussion

I have the same problem but it is not as bad as yours. I think that we will have to wait for the next firmware update before that is fixed.


I am going to upgrade my old APM2 on my Y6 today so we will see how level it comes out. With a Y frame it’s a real pain to do the new calibration.




I just got 2.9.1 installed in my Y6 APM2 and it was level after doing the calibration. I did the calibration with the board removed in the plastic case. I had to remove it to do the PPM Encoder update anyway. That way I could easily get it level in all axies. I had only the USB cable connected – No GPS – NO Receiver.

I think that I will try the same thing with my Quad with APM 2.5 and see if I get a better calibration.




 i had the seem problem .it only started when i put my 2.5 in the plastic case .

it turned out that the board  could move around in the case . so i used double side tape

to hold down the board to bottom of the case . seems to work at keeping it level so far...

I had the same problem on two 'copters. The one would not respond to leveling using CH7 or redoing the accel calibration and I finally reloaded the firmware, erased the EEPROM and started again - success. The other required just very careful calibration and making sure the copter was vertical/horizontal.


Hi Simon, I had the same problem. Levelling my hexa with Mission Planner or using in-flight trim didn't work. What finally worked was using the fields AHRS_TRIM_X (roll) and AHRS_TRIM_Y (pitch) in the Advanced Parameters List. These values are in Radians, so be careful what you enter and check the results while on ground. Worked perfectly for me.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service