Issues with XBee PRO and XStreamBee adapter board

We recently purchased a pair of XBee PRO (Series 2 Mesh, S2B) and the XStreamBEE Board and have had nothing but problems.

First, the USB to FTDI cable is not recognized by any computer we have tried, in either Windows 7 or Linux. Plugging in the cable does not cause the computer to see a new device. No voltage is seen on the 5V pin on the cable, LEDs on the xbeestream adapter do not light up.

We then try to interface the adapter directly with an arduino, using the arduino as the USB to serial adapter. It works intermittently at best, but the power LED will often blink along with the TX and RX lights.

We also tried using this adapter with a series 1 point-to-point xbee. It behaved the same, but then it bricked our xbee, and now we can't even connect to it with an adapter we know is good :-(

Has anyone had similar problems with or any success with those XStreamBee boards?

XBee Pro S2B:

XStreamBEE Board:


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi guis.

    I see very strange problem.

    When I connect my Xbee Pro S2b (version XBP24BZ7) to X-CTU select port and press test

    it shows device version "smth unreadable" and when I try to read from Xbee it try to updte firmware, downloads new firmware from internet and then shows "unable to find firmware file".

    I tried to set firmware manually to "XBP24BZ7 Coordinator AT" with serial baud rate 9600 (and 115200 also) and it burns the firmware successfully. Then it reads parameters and work fine. But when I disconnect usb-serial and connect it to PC again, it fails to read version and other parameters. and I need to write firmware and do the same procedure again (if I disconnect device from PC).

    Xbee connected to PC with usb-serial connector:

    GND-GND; VCC 3.3 - VCC 3.3; TX-TX; RX-RX.

    I tried to do the same with fdrobot extension shield (set with 2 crossover jumpers) and have the same problem.


    I have a new Xbee pro adapter from Jdrones I am having trouble to work withe the Xbee pro 90 XBPO9-DP module.

    I know its not the module that is the issue because I have another adapter that the module works fine with. I have tried both the baud 57600 and the 9600 but I always get the popup instruction to push the rested button. Ive tried the reset using a jumper to connect the GRD and RESET on the adapter board but nothing happens.

    I have followed the instruction above here how to reset/unbrick the adapter and module to reset the firmware. Nothing works.

    I am using the FDTI cable. When I plug this in I get a blue LED on right top side of the adapter that lights up which seems normal compared to my working Xbees. When I open X-CTU and click Test/Query a green LED to the top left of the adapter blinks for a few seconds and then goes solid green when the "Action Required" box pops up. That's as far as I can get it to go.

    Ive tried to upload the firmware from my other Xbees, but nothing works because the X-CTU cant communicate with this adapter. Any idea why this isn't working and how to reset the adapter (not the module)? Note, this all works fine using the FTDI cable on my other two Xbees.

  • Well, Well!!

    For 2.4 XBEE Pro S2B on Sparkfun adaptors only.

    After searching for hours and hours the soloution seems to bee :-

    Always read the settings before you change something so that only the bits you want are changed.

    Always start the sequence by loading the defaults into X-CTU

    Always read back the settings after you change something.

    1 use the config XBP24BZ7 settings both ends 1 is Coordinator AT the other is Router AT use the default baud 9600.

    2 do these steps for both units

    3 read back the settings so that you can see  serial number high and low, write them into notepad

    4 set the pan id to something you want.

    5 do 3 to 4 again for second unit

    6 for both set the destination high and low to the serial number high and low of the other unit.

    7 now just change the baud to 57600 and remember to change pc settings to the new baud rate

    If this does not work I don't know!! but it's taken a week to find this out. XBEE'S are great!!! (now).

    Thanks to the people who replied.

  • Make sure you can use the FTDI cable with XCTU. before you do anything else.

    If you have 2 FTDI cables, you can hook both up to a computer, start one in XCTU's terminal and another in hyperterminal and you'll see echo-ed output when you type in one of the terminals--at 56K settings of course. If that works, then your xbee link is 100%.

    Note on sparkfun boards and 900 Digimesh modules, the line level is too low due to the board's limited output (i.e. experiences brown out)--you need activate the pull-up resistor option in the xctu configuration.

  • No idea, beyond my scope, but figured I'd let you know someone is reading these...

    I am running the xstream bee (3rd one now) with the xbee pro 900s.  I didn't need to go that deep into the cofiguration.  It has been troublesome, and I still think it was the xstream adaptors that were giving me issues, beyond that I am of little help.

    First xstream froze completely, I had to undrick actual xbee, still wouldn't work, second xstream adaptor, lights were on and flashing, but no body home, xctu wouldn't even acknowledge there was a xbee connected, third xstream board has worked like a champ, no problems...




  • Hi Jeff,

    I have had little success with S2B, but I have had some!

    Here's the score so far,

    Changing the config with digi's utility to XB24-B and using zigbee AT co-ordinator and zigbee AT router/end device with pan id set to a useful value puting the one device on a breadboard with it's adaptor and just 5V Gnd and Din linked to Dout and the other device on a usb adaptor with X-CTU running on a PC I can use the range check page and get 100% data exchange.

    This also works after a fashion with Mission Planner but there a long periods of no data!

    I'm using xbee pro s2b with 1 sma and 1 wire antenna and the sparkfun boards. No FTDI cable.

    I program with the usb board.

    Questions :-

    1) Does anyone have the series 1 xbee config that they would share so that it can be tried?

    2) Does anyone know what commands ardupilot uses if any, it might just assume correct settings.

    The best thing I could hope for is a profile file that has all the series 1 settings in it for X-CTU, PLEASE ! !

    If I find anything else I write it up here.

    Thanks for reading this.

    John Fletcher

  • Hi Jeff,

    Have you managed to feet your xbee's working? I have the same units and can't get them to work either. I can set them to talk to each other via terminal but mission planner can't connect.



  • Hi, not sure if it's true or not, but in the APM wiki it clearly is not recommended for theseadapters modules than the xbee 900MHz (xbp09-DP) for modules such as thoserecommended his Adafruit or Sparkfun.

    I can tell you that I bought the same adapter modules 3DRobotics with Xbee09DP andgoing very well.

This reply was deleted.