I have just bought a Minim OSD and got it all soldered up. I am running it on the ground rather than in the plane as I want to be able to see the OSD even if the video glitches when I am at long range.

 

I have encountered a strange problem that I am hoping I can get some help with. When I plug the OSD into my goggles or computer without an input video stream into the OSD, I can see the OSD perfectly with a black background. All of the information coming from the plane is there and it responds. Once I plug in the video feed from my video Rx, the OSD information just dissapears, all I can see is the video feed. It's clear, but there is no OSD information any more. As soon as I unplug the video input into the OSD, the OSD information reappears on my screen, with a black background.

 

I did some playing around, and it appears that the PAL signal being put out by the OSD is a PAL M type. Which is 60Hz and 15.750kHZ horizontal freq. I checked the specs of my PAL camera on the plane, and it is 50Hz with a 15.625kHz horizontal freq, also known as PAL N.

 

Could this difference by the cause of my problem? Is the minimOSD having problems syncing the camera feed to the OSD layer? Is there any way to fix this in the firmware?

 

Regards

JAmes

Views: 10754

Reply to This

Replies to This Discussion

Ok, some more investigating reveals this - If I plug the output from a DVD player into the MinimOSD, I can see the OSD display over the top of it. Everything works as if it was in the plane. If I put the output from my Duo5800v2 rx into the MinimOSD, all I get is the video and no OSD. If I unplug the video, I can immediately see the OSD layer against a black background.

So the cause appears to be something in what the reciever is doing to the video output I guess. Or possibly the camera itself. The camera is a WDR700 from BEV RC (PAL camera). The resolution of these is quite high at 795x596, but close to a DVD.

Is the chip unable to manage resolutions this high? What is the resolution of the OSD itself? Are there only certain cameras that work with MinimOSD? If so, this needs to be made very clear when buying one.

 

If it is the receiver, does anyone know if it would be doing something special with the image? Don't they just output whatever the camera was outputing?

 

I'd really appreciate some help on this.Are there any MinimOSD gurus out there?

 

Regards

James

James,

 

If you connect the video out from the camera straight to the OSD (without the TX/Rx) will it display correctly?

This problem is mostly fixed. I replaced the camera with a lower spec OSC480 from bevrc and it works. I still have issues with the OSD layer just dissapearing when viewing some backgrounds, but Im closer.

So think about it before buying one of those nice high tvl cameras. Image quality is good, but it might not work with an OSD. This has been reported for other OSDs using the max7456 chip, as well.

I have the same problem with minimOSD, Gopro HD1 cam, and APM2.O

OSD displays fine. Soon as I plug cam in, OSD dissapears and video is seen.

I am using osd powered by apm (connections on osd closed) no power going in or out on opposite side of osd.

Hi dudz.
I assume you are using the OSD on the plane side. All my problems were when I tried to use it ground based through my video rx and xbee. On the plane side it works for me. I still get one problem - when plugging in the video, I always need to hit the reset button on minimosd, otherwise i just get the video with no OSD overlay. I think this is because the minim chip is powered by APM so is running when I start that up, and before I power my camera.


I assume you have tried reseting the board after pluging in the camera?

Another option is to try a lower res camera or set the gopro to a lower res setting ( not sure if that is possible since I dont own one).

I think the maxim 7456 chip may have some upper limit on the resolution, but its hard to find what that number is.

Thanks James,

 I have the OSD on my Y6. (no xbee) through video rx.  I tryed the reset button after turning on the gopro. It works !!! .. thats brill thanks. But will I need to do this everytime ? I have put both APM and OSD in a plastic box with transparent lid (for gps) and some holes for baro. That would mean undoing 4 long screws, pressing the reset and doing the srcrews back up (a pain in the arse)  I will try the gopo on low res later on.

Unfortunately, I have found that I always need to reset the OSD after plugging in the camera or I get no overlay. I'm not sure if this is a hardware or software bug at this point but I will investigate the software side.

It may be worth mounting your osd board close to the edge of your box and drilling a hole so you can hit the reset button with a stick or something.

Alternatively, try powering and plugging in the camera before powering APM & the OSD. I have a theory that it is initialising itself based on whatever video signal is present at startup.

I have moved mine to allow easy access to the reset button as it is not practical for me to plug in the camera before the APM/OSD with my setup. It is annoying when I forget to do it and then find I have no OSD once I am up in the sky.

 

Cheers

James

I have to hit the reset button on my minimosd every time I power on too. When I power on, I will just get static through the video feed, then pressing the reset button makes the video appear properly, then I see the minimosd boot up and it works normally.

Using a Pixim seawolf wdr camera (PAL), but also get the same thing if I plug straight into my gopro.

It is because of the standards. Like MinimOSD boots up as NTSC and you connect a pal cam, than osd "goes away"..  there is a section in the code. Like i fixed my MinimOSD to PAL and no problem anymore. ;)

If you need more help, write me.

I have a 600tvl camera and having the same issues you descibe.. even with latest config tool and firmware.. (v1.0 MinimOSD)

I have another camera a 480tvl one it it works fine..

Reset button doesent work for me.. either I have to power up MinimOSd first then camera or unplug video from MinimOSD and plug back in..  after that I get OSD overlay ok..

Have soldered the pads on the back for PAL (pal camera) but I understand in latest firmware that the pal/ntsc setting is setup in the config tool and that the pad is ignore ?..

Is there a fix for this.. ?.. or is it the case that the chipset doesent support high tvl cameras ?

If you use Official 2.0 or latest MinimOSD-Extra, they bough use the same method for setting standards.

No more auto detection, as many people is turning there cameras on after MinimOSD booted (include me), so this way that was a problem. If you know that your camera is PAL or NTSC than simply chouse it in CT menu than make a write than should work. No bug here. 

Yes soldier jumper is ignored.

What camera are you using?

Gábor

As per Gabor's comments. Using any recent MinimOSD-Extra release I have no more problems, even with my new 690TVL Pixim Seawolf camera. It was all down to the initialisation of the chip which has been fixed in this code.

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service