MinimOSD - Black screen/no image

Hi all !

I need help about my MinimOSD freshly unpacked.

I've triple checked the cabling and I don't know why I've just a black image on my screen.
There is a suspicious comportement when I power on the system. I explain how it happens:
1. Connect correctly the Vin/Vout/RX/BLK between APM, MinimOSD and video transmitter 
2. Power on the APM 
3. Connect the battery balance connector 12V to the MinimOSD  

At point 2, the ST led (orange) blink and the D PWR (red) led power on and still.  
When I do the point 3, the ST led shut off and the A PWR led power on and still. 
After that, I just have a black screen... It's weird because the system worked at least once!  
The firmware is up to date and I use a XBee but I've not connected the TX port on the minimOSD.

What's wrong ? Someone can help me ?

Thanks in advance ;-)

Jerome

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have the exact same issue. I can still talk to the MimimOSD via FTDI, and have tried updating the firmware, but that does nothing. I've also tested the TX, thinking maybe that was the issue, but it works fine when connected to my DirectTV receiver. I also noticed the failure happening slowly. first it was just that my video had some flickering to it, then it was no video and OSD screen only, then it was OSD stuck on the OSD boot screen, now, nada. It seemed to get worse when I loaded the newest firmware. I also notice its getting pretty warm. One question tho, can you bypass the OSD and go from the Camara (say a GoPro Hero3 Black) straight into the TX? I tried that and I still didn't get anything. I'm so confused.

  • Doing further tests I find that when I first power up the board I get the black screen. However if I leave it powered up for a minute or so I then get the camera ( video input) outputted from the board, at this point if I then press the reset buttom the OSD data then fires up and everything works just fine until I remove power for a minute or so and then its back to the black screen.

    Andy.

  • I have just received another MinimOSD v1.1 as a spare for the one I have running on my quad. However when I connect it up in place of the one I have running I get no video out, just a black screen. However on a couple of ocasions whilst fiddling with the board and pressing the reset button a few times it has burst into life and started working ok. However if I then cycle the power I am back to the black screen once again. I can alter settings and upload firmware and charsets ok with no problem and the wiring (power, links etc) are all ok and checked against my fully working board. My first thoughts was that the MAX video chip was fried/DOA but after the 2 times I have had it up and running ok not so sure.

    Andy.

    • I also have just experienced this, My set up was working well then I tried to change some info on panel 1, when I plugged it back together all I have is a black screen.

  • Thanks for this. I really thought I had killed my OSD too, soldered those pads and just powered from the 5v, works fine. Single battery setups are the way to go.

  • I had exactly the same problem with minimOSD from HobbyKing that initially for few months everything was OK and then suddenly back screen no matter what I did. I measured the components and could not find the issue.

    Then I moved to single power source from APM only (I shorted the ground and power pads on minimOSD) and everything started to work again. ...no idea what the exact issue was, but as it's working with single source I don't care ;)

    • It doesn't make sense, what you're claiming. The video in and out pins are connected. There is no mysterious gate between them. The video overlay is additive. The only way to get a black screen is to not have a common ground on the video signal.
      • This is not correct: in the minim OSD the video_in and video_out are separate pins and  they are not connected.

        If the maxim chip is fried (or just not powered), you get no video signal at all.

        • I can confirm this is true on the 3DR 1.1 minimosd.

This reply was deleted.

Activity

DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
yesterday
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
yesterday
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
yesterday
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars @donkey_car virtual AI car race is starting in 15 minutes! Watch it live on Twitch https://www.twitch.tv/mossmann3333 htt…
Saturday
DIY Robocars via Twitter
RT @chr1sa: Don't miss our monthly @DIYRobocars @donkey_car virtual AI car race tomorrow at 10:00am PT live on Twitch. Head-to-head racing…
Friday
DIY Robocars via Twitter
RT @sparkfun: Our completed tutorial on building an @NVIDIA Jetson Nano-powered @Sphero RVR gets your bot up and running via teleoperation…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Freeway test https://t.co/4V5tV9lhIP
Thursday
DIY Robocars via Twitter
Very small autonomous cars racing, thanks to an overhead camera: https://control.ee.ethz.ch/research/team-projects/autonomous-rc-car-racing.html
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
RT @chr1sa: Don't miss our virtual AI car race this Saturday! Real developers + virtual cars =🏎️🏎️🏎️ Head-to-head battles with thrills, sp…
Jul 28
DIY Robocars via Twitter
Jul 27
DIY Robocars via Twitter
RT @usashirou1: Jetson nano by Isaac Kaya #jetson https://t.co/Mu1N0CyQkN
Jul 23
DIY Robocars via Twitter
RT @GPUsolution: JetRacer mady by Iflytek company #JetsonNANO #Nvidia https://t.co/MimTymIwge
Jul 23
DIY Robocars via Twitter
RT @openmvcam: I love this: Mega or Mini? Image Classification on the 1MB OpenMV Cam H7 by Ish Ot Jr. in OpenMV, Edge Impulse, Internet of…
Jul 23
DIY Robocars via Twitter
RT @RoboticMasters: This is looking pretty good... but still needs a bit more refinement. Pure OpenCV Turning Sign Detection. No Tensorfl…
Jul 23
More…