MinimOSD issue- No on screen overlay


I've set up my minimOSD as per the diagram below, and, my Transmitter, Camera all work fine, however, there is no overlay data from the APM through the minimOSD board.

When I first set up the configuration below, the minimOSD board showed a progress 'booting up" bar on my screen, then paused and would stay at "Update Char Set".

  I purchased a FTDI serial converter, and using the OSD_Config software, I updated the firmware, the character set, and saved the current 'tab' to the OSD board. Done.

When I plugged the minimOSD back in to my setup, there's no telemetry overlay.

I've tested my 3DR radio and it sends all my telemetry data to the mission planner fine, so the 3DR Radio and cable are working.

I've even set up the 3DR radio and minimOSD in parallel, (making sure the tx is not connected), and, still no joy.

  • The only thing I haven't done is solder the D GND and A GND, and the D VDD and A VDD, because I have a secondary battery powering up the FVP camera and Transmitter, as in the diagram.
  • And, the telemetry cable from the APM has an extra GND wire going to the 6th pin from the top, (as in the diagram), and, I've left it there as I don't think an extra GND would hurt or help.
  • Bad board? How would I know?

Anybody have any ideas?

What am I missing?



You need to be a member of diydrones to add comments!

Join diydrones


  • Hey guys.  Just reading this post and thanks! 

    BUT, I have this problem similar.  Basically I get NO OSD on boot, if I disconnect the camera feed into the board then reconnect it I get the OSD and video.....  wtf....  Somebody mentioned the board doesn't detect PAL very well sometimes..?

    Any ideas?

    • Which negative wire? The camera negative? Thanks for your help. I have fought this for quite awhile.
      • i forgot to say im using software.  i bet problem is the same on booth .. something with max chip and camera sync

        MW OSD
        MWOSD MW-OSD multiwii osd KVOSD baseflight cleanflight
      • Yeah mate, ground for cam.

    • I am having the same problem, I am going to change the camera and see if that gets it going. Currently overlay works until I connect the camera. Thanks for all the help.

      • I ended up putting a toggle switch on the neg wire.  So I fire the system up then toggle the switch (on/off) and the OSD is there.

    • i got my osd set up first time and got same isue, after reading all what i can find i solved my problem by uncomenting line

      #define AUTOCAM   

      it seem something mesing with as you say PAL/NTSC detection. 

  • This is an old thread, but I have pertinent info to add.  I experienced the same issue as the OP but finally happened on my issue after reading through this thread and many sleepless nights.  Turns out my minimosd doesn't like my camera.  I have a PZO420 and a fatshark 600TVL camera.  I can't get my whitespy, my multirotormania board, my hobbyking minimosd, nor my radiotoflyquads minimOSD to show an overlay while using my fatshark camera.  If I switch over to my PZO420 I have no issues.  

  • I wanted to let anyone know I found another problem and solution. I have a 3dr APM 2.6, a HK mega mini and a HK Mega 2.7 (APM 2.6 with fixes). I could not get the minimOSD to overlay data on any of those FC. In trouble shooting, I discovered that the voltage coming from the APM's Tele/OSD y-cable was only outputing 4.6 volts. I replaced 5+ and GND to the OSD (leave the Rx wire) with power from a UBEC (powered by the FC battery) and its been working! I also check the power coming from the 3DR Power Module and it was outputting 5.1 volts. So it appears that that APM is dropping the PM's BEC from 5.1 to 4.6 volts. 

    Hope this helps anyone


    • Thanks Chad, solved my blank screen problem by powering my minimosd separately, not from the Tele/OSD Y-lead.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25