Hello there,
I have decided to start a new discussion on this subject as I can't understand why from time to time and without notice, my Minimosd will clear the screen from data overlay and what I get is clear video from cam. all looks to work perfectly before this happens and sometimes, too often I would say, Overly disappears without any notice.

first of all, I would like to know if I am the only one who suffers from this symptoms.
If any of you out there experienced or experiencing the same phenomenon, please come forward before I loose my sanity :-)


My Setup:
APM 2.76, minimosd extra r710, 3dr hw ver 1.1, 3DR telemetry. OSD is powered from APM 5V ( parallel to telemetry port without TX connected - only RX,GND, +5V), all soldering pads are soldered. Voltage is constant at 5.20V at all times.

Please remember - all looks to be working great, and out of the blue overly goes away like an invisible hand pushed this non existing OFF button which by then switching panels stops working - no control over OSD.

this can happen just like that without doing anything, or when switching to RTL using my remote control,  etc..

This happens with two of my identical minimosd's.

Thanks U.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


              • when you say you took off the 5V power supply from the APM, did you replace it with anything?  

                I notice one poster said that was a solution, but with the OSD I have, the 5V side was not powered (I have not modified it to connect the two sides of the board with the two blobs of solder), so I replaced the 5V power and ground leads from the flight controller with 5V BEC power (from a separate BEC), and that solved my problem.

                So my solution was to keep the 12V side powered as recommended, but replace the 5V power with a  BEC supply instead of from the flight controller, and I haven't had any brownouts or reboots since.

                • New OSD i bought it came with soldered connecting the two 5v rails so i simply disconnected the power from APM, thinking power supply that inside the OSD could power it self.

                  to your question no there no extra power supply powering the osd.

                  I'll try your solution but i dont know whether its going to help.

                  • It was not the power line issue. it was more than smooth enough to handle. I checked and i did what you said to do, Nothing helped. Finally i realize my BEC is so close to the osd and its not shielded. I removed it and placed it somewhere. Wola it worked. BEC could be a big problem it is it not shielded.

                  •  Separate clean BEC power on the flight controller side worked for me--but not sure what will happen if the two sides of the OSD are already connected with the solder blobs--that's beyond my electronic knowledge.  Good luck and let us know how it goes.  Seems like there is a problem in the design of MinimOSD (or at least its clones) that needs to get worked out.  Cheers

  • Hi guys, I think I may be on to something. At least for me, the issue is RESOLVED! I was having the problem that the OSD would boot and then work for a period between 0-120 seconds, usually less than 20 seconds.

    Findings: While powering only the 12v side for fiddling with my cameras, I noticed that all of my quad lit up, Telemetry, APM, reciever... whoa... there must be a connection between the 12v and 5v side! Even though I did not solder any such connection on any of mi MinimOSDs!

    Summary: There is some kind of back currant going on, probably overheating or overwhelming the minimOSD.


    Remove the +5 red lead from the socket that connects to the minimOSD. You'll only have GND and TX connected. I now have two successful OSD flights, compared to zero before.
    The 5v is probably getting powered from the 12v side.



  • I have the same issue in a different way. My OSD freezes when take off my quad. Every time when i start spinning minimosd freezes.  i have everything showing on the screen but nothing updates even the time freezes. I checked everything including my power system. Nothing so far. I put extra filters to ubec and i power the 12v line with extra battery and still freezes.

    • Are you powering your minimosd from the same battery as the one that gives power to the motors ? If you power them separately you will get nice even power for both sides and your video with overlay will be steady.

      • I tried using two batteries and it was the same results. I have a 4s setup and 12v side goes though a stepper to step down to 12v so that should help it eliminate noise but no help.

        I have two OSDs and one is a newer version of the OSD so it has the small switch mode power supply built in but same results. Other one simple does not have the diode connected so it completely run out of the APM.

        Next test would be running the APM completely out of a 5v battery so that i can test the noise on the APM power rails.

  • Hi all,

    I'm having the same issue. OSD works for a while, then vanishes. Picture still there. Same thing with two MinimOSD's I got from Ebay.

    If I press reset button, they will come back showing "minimOSD booting, requesting Datastream", then go blank.

    I get the feeling that the APM is telling (via the mavlink commands) the OSD to not display anything.

    Today the OSD worked upon cold start, I started in Loiter, took it up, switched to "Stabilize". Poof, gone.

    Seems to work well for many minutes when its on the workbench. I have it disarmed but am switching between modes. Works fine. Works for less than two minutes when I'm actually flying.

    My OSD Toggle channel is set to "Disabled".

    Using Arducopter 3.1 and MinimOSD 2.0.



    • Bumping this as I too have this issue, some times it's fine, others it doesn't even display. I know heartbeats are still being sent as the telemetry to my taranis doesn't drop out. 

This reply was deleted.