Mission planner Crash after update


Every time I run an update on the mission planner it crashes (this only happens on the new version).


I retrieves all the files and when the command prompt window runs it crashes. Please see screen shot below.


And when I load ArduCopter 3.01 on my quad and try to connect with my 3DR radios it times out where as version 2.91b connects every time (I can upload firmware I cannot connect via MavLink) so I am no on 2.91b.


I am not sure if this is because of the mission planner crashing on update or because of the arducopter code.


Kind Regards



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Although I replied to this post that I've not had any difficulties with MP, I did encounter connection problems after an update to 1.2.73

    MP would not connect with APM , also MP seemed to get hung up when I tried to select a COM port.

    The solution, for me, was to turn off the BlueTooth radio on the computer.  

    I guess that the BT COM ports were causing an un-resolvable condition and  Mission  Planner would eventually time out but it seemed like it froze until the time out expired.

    This has happened before but I had forgotten about it and I had to re-discover the solution.

    I'm using US english & my computer is running Win7  pro   64-bit.

  • Developer

    Im starting to think you need to reinstall the .net 3.5 framework.
    as ive had a look at the changes in the last version where it crashes, and there is nothing that would cause a fatal crash like that.

  • Hi, Michael
    A there any decision problem with crash of MP version 1.2.70 with log:

    2013-08-19 14:19:18,981 INFO Program - ******************* Logging Configured ******************* (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Program.cs:33) [1]
    2013-08-19 14:19:21,275 INFO ArdupilotMega.MainV2 - Mainv2 ctor (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\MainV2.cs:190) [Base Thread]
    2013-08-19 14:19:21,483 INFO ArdupilotMega.Utilities.Speech - TTS: init, mono = False (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\ExtLibs\Utilities\Speech.cs:43) [Base Thread]
    2013-08-19 14:19:21,547 INFO ArdupilotMega.MainV2 - Create FD (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\MainV2.cs:318) [Base Thread]
    2013-08-19 14:19:21,620 INFO ArdupilotMega.GCSViews.FlightData - Ctor Start (c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\GCSViews\FlightData.cs:130) [Base Thread]

    May be the point is in national (russian) version of Windows 7 64-bit?

  • Developer

    try starting MP as administrator.

  • In flight planner, MP 1.2.70 returns a 3 digit altitude when:

      making a wp with default alt <100 and verify checkbox is checked


  • Same here: netbook with N450 and intel graphics (each software is latest version) does not work. 1.2.69 works just fine.

  • I'm running MP Version 1.2.70 on Windows7 64-bit  and it works just fine even though my computer is long overdue for an OS re-install  [ blue screen of death once or twice a week].

    The com port selection in  MP can be slow to respond and connect sometimes ,not always just some times, but it probably my computer that's at fault since it has been that way with many previous versions of MP.

  • I am have a problem with Mission Planner, it works perfect until I close it.  When the "X" is pressed the MP window closes and the box pops up and says "Mission Planner has stopped working".  This happens everytime I close MP.  I am currently running MP 1.2.70, NET 4.5, Windows 8 on my Windows Surface Pro.  Attached is the MP log, can someone have a look and see if they can diagnose the problem?


    Cheers, Todd


  • I have problem too. Win7 Pro 32bit SP1, WinXP Pro 32bit SP3.

  • MP crash after update to 1.2.70 version.


This reply was deleted.