Motors twitching in flight

I have started this dedicated thread at the suggestion of another contributor.

This issue has was raised on the main 'Arducopter 2.8 / 2.8.1 released' thread and can be viewed here.

I'm still puzzled by this twitching, however look at the latest log from today and in a little more detail I can see a very small change in the THR IN trace which appears to be directly connected at the time all the motors twitch (see below).

Is the THR IN trace taken straight from the Rx ?

Not only have I done the things as detailed in the main thread, but I have also:

Grounded the aircraft (in case of interference)
Repositioned Rx to top stack
Reprogrammed all ESC

I have attached the latest log.

Would dropping the ESC Update Speed in MP from 490 - 400hz help ?

Any suggestions would be appriciated, in the mean time i am trying to get hold of a duplicate Rx.  Any chance it could be the APM ?


2012-11-09 13-17 179.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    One great way to overcome problems with PWM to PPM (back-)conversion is not to use it.

    I can recommend the FrSky TFR4 receiver for FASST. It is small, inexpensive, works with 7CH and "multi" as well, it has a direct PPM output with 8 channels, it has diversity and it has an RSSI output.

    It will also rid you of half a dozen servo jumper cables :)



  • As a noobe for the last month, I too have been having terrible jerks using my T8fg and 6208 receiver with rx channel output to channel input connections.. I tried multiple combinations of equipement and mods without success.. I have recently found this very helpful thread, so decided to pull out my old JR10x radio with XPS 2.4 systems.. WOW.. no more jerks from spikes.. Huge revelation.. Thanks Steven, et al, for sticking with the problem and nailing the Futaba radio as the problem.. 

    Can I use the PPM encoder board with the new flash firmware and get this Futaba radio to work?


  • I am trying to load the new PPM encoder into a couple of V1.4 boards I have and have run into a couple of problems.

    Following the Wiki instructions:

    Using the the AVR ISP Mk2 I first tried downloading the latest AVR Studio 6, unfortunately the stk500 is no longer an exe but an xml file??

    So I tried downloading AVR 4.19 and all went well up to the reading of the FLASH input file where I get the error "could not read FLASH input file firmware.hex" and the procedure aborts.

    I had downloaded the latest ArduPPM_v2.3.13_ATMega32U2.hex placed it in the folder with firmware_arduino_328_16mhz.bat and renamed it firmware.hex.

    Am I missing something here?

    Any help would appreciated.


  • Excellent work any chance we get an explanation as how you solved this problem.
  • Many thanks for your sterling efforts in nailing this problem.

  • Developer

    Official firmware for APM 2.x released.


    - New interrupt system that handles certain Futaba receivers better
    (simultaneous changes on groups of R/C channels in fast intervals)
  • I've done about two hours of bench testing with the experimental firmware and now about an hour of flight. Everything has been flawless, not a single twitch across those three hours and behavior otherwise was as expected. It's raining all weekend so I'll not get more time on it for a few days, but I'll post some logs when I do.


    I'm flying a Futaba 12Z. I've had this problem since at least 2.6 (see

  • I have problems uploading my files. i try later may be the host is down or something.


  • Can anyone give a time frame as to when this issue will be resolved ie: new PPM encoder released.

    The reason I ask, instead of remaining just patient, is I have been asked by a power company to pull some lines over rough country, and as I use Futaba and get these spikes, I would really, really like to get this problem resolved, as everything else in the system is working so well.

    I have a test platform that I would be happy to use to do any additional testing if that would help any.

    But the heavy lift drone is NOT something you want to be around if it glitches.

  • OK I am using Futaba 14MZ on mine if that could help you too !!!!

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25