MP 1.2.58, 1.2.59 can't browse for logs on new Surface Pro

Many apologies if this has already been asked and remedied, I wasn't able to find anything on a search..

Just got a new Surface Pro 128 the other day and have loaded MP on it.  I haven't yet connected to an APM, but wanted to review logs while on a very long flight from San Diego to London.  MP is locking up as soon as I hit the "Load Log" button under the Telemetry Logs tab, and also under the "Tlog > Kml or Graph" window when I hit "Graph Log." 

I've uninstalled and reinstalled a few times, stepping back and forth between .58 and .59.  I then started to suspect problems with the .NET Framework, so uninstalled and reinstalled that via Win8's add/remove features.  I have tried installing 3.5sp via the download and when I click on the downloaded file, it doesn't seem to do anything.

I started focusing on the framework then, and cranked up a quick .net app (making sure to use v3.51 as the runtime in the IDE) and coded a button to open up the file dialog like this:

private void button1_Click(object sender, EventArgs e)
{
OpenFileDialog ofd = new OpenFileDialog();
ofd.ShowDialog();
label1.Text = ofd.FileName;
}

The file dialog opens fine.

Has anyone else run in to an issue like this, or does anyone have any suggestions on what else I can do?  Is a connection to APM required at least once before the review of any logs, or is that unnecessary?

Josh

Views: 533

Reply to This

Replies to This Discussion

Anyone have any thoughts?

please wait a little longer. I think it will be loading.

Thanks for replying Michael.. how long are you thinking?  I'm already in the "hours" category :(

can you goto help, and turn on the console window.

then restart mp. and see what it says when opening the log

Nothing gets added to the log.  I see all the HUD Resize entries, etc, but when I click "Load Log" nothing happens.  I push the button and the control doesn't even unclick.  Very weird.

I get prompted to upgrade, so I select yes, and that never works, and when it fails MP then crashes on shutdown.  I uninstalled completely, deleted the folder, reinstalled 1.2.60, and that is the version I clicked to show the console on.

Happy to do a screen sharing if you're so inclined.  I'm 100% positive this is an issue with MY Surface Pro and not MP, but very much appreciate your help getting it working.  I have two other Win8 machines that run it fine, but the Surface is the tool I want to use at the field so I'm keen on getting this resolved.

something to try.

in the planner config, try changing the log directory.

and, try disconnecting from wireless/network. and try.

see if that makes any diffrence

Dropped into Airport mode, went to Software and clicked Browse next to "Log Path" and it froze in the same fashion it did when I try to browse for the log.  Closed it, opened it, tried typing manually a path that I wanted to use (C:\Logs) but it wont stick.  

Where is that config stored in the system, perhaps I can modify directly?  It's not in ArdupilotMegaPlanner10.exe.config where I thought it was.

Suspecting it is having trouble invoking the file browser from .Net but not sure how to verify

config.xml

and

<logdirectory>

Interesting, that key doesn't exist, even on the laptop that works.

I added it and no change.  

I tried:

<logdirectory>C:\Logs</logdirectory>

 and 

<logdirectory></logdirectory>

Here is the whole file:

<?xml version="1.0" encoding="us-ascii"?>
<Config>
<comport>AUTO</comport>
<baudrate>111100</baudrate>
<APMFirmware>ArduPlane</APMFirmware>
<TXT_loiterrad>45</TXT_loiterrad>
<TXT_WPRad>30</TXT_WPRad>
<Tracker_CMB_serialport />
<Tracker_CHK_revtilt>False</Tracker_CHK_revtilt>
<TXT_homealt />
<Tracker_TXT_tiltrange>90</Tracker_TXT_tiltrange>
<Tracker_TXT_pwmrangepan>1000</Tracker_TXT_pwmrangepan>
<MainHeight>576</MainHeight>
<Tracker_CHK_revpan>False</Tracker_CHK_revpan>
<maplast_lng>0</maplast_lng>
<MainLocY>53</MainLocY>
<CHK_GDIPlus>False</CHK_GDIPlus>
<maplast_lat>0</maplast_lat>
<NUM_tracklength>200</NUM_tracklength>
<CHK_altmode>False</CHK_altmode>
<TXT_homelng />
<TXT_DefaultAlt>100</TXT_DefaultAlt>
<showconsole>True</showconsole>
<Tracker_CMB_interface>Maestro</Tracker_CMB_interface>
<MainMaximised>Normal</MainMaximised>
<FlightSplitter>358</FlightSplitter>
<TXT_homelat />
<Tracker_TRK_tilttrim>0</Tracker_TRK_tilttrim>
<Tracker_TXT_panrange>360</Tracker_TXT_panrange>
<Tracker_TXT_centertilt>1500</Tracker_TXT_centertilt>
<menu_autohide>false</menu_autohide>
<MainLocX>128</MainLocX>
<MainWidth>1024</MainWidth>
<Tracker_CMB_baudrate />
<update_check>7/12/2013</update_check>
<Tracker_TXT_centerpan>1500</Tracker_TXT_centerpan>
<Tracker_TRK_pantrim>0</Tracker_TRK_pantrim>
<Tuning_Graph_Selected>roll|pitch|nav_roll|nav_pitch|</Tuning_Graph_Selected>
<Tracker_TXT_pwmrangetilt>1000</Tracker_TXT_pwmrangetilt>
<maplast_zoom>3</maplast_zoom>
</Config>

Attachments:
Hi everyone,
Im Trying to decide which way to go w8 or android tablet for the field,

I would like to know if somebody has an experience of running mp on a w8 tablet and compared it with the droid planner app running on an android tab.

Is mp on a tablet practical ?, can I replace the netbook with tha tab?

Is it possible to have video on the android tablet via USB with an adaptor, ?

Any very visible pro or con , to decide for one or the other ?

Thank you very much for help,

Sorry to be a bother Michael, any other thoughts or should I re-install the Surface?  Is there any validity to the thought of plugging the Surface into an APM once before it'll be able to read logs?  I can't see that being a factor..

Ok so my buddy Scott just sent me this.  Fixed.

http://www.diydrones.com/forum/topics/mission-planner-crash-after-w...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service