nmea sentences


I am planning to use a novatel oemv receiver as the GPS for my plane. I am using arduplane 2.78 and APM 2.5 

I know that ardupilot is happy even with nmea. The question is which $gp... Sentences are enough to be activated in order to do the job.

Thank you

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am back i am also trying to pass the nmea data to apmplane 3.1 with no success. I have a novatel oemv2 l12 receiver. I configured the correct baud rate etc but no luck. I also enabled all the available nmea sentences through the great and very helpfull lefebure conf utility. It is strange as i configured an old lea-4t receiver to output nmea and it worked with the apmplane.....

    I will test again the next days and i will report.

    • Napoleon, can you post some of the NMEA strings of the LEA-4T?
      • 08:11:10 $GPDTM,W84,,0.0,N,0.0,E,0.0,W84*6F
        08:11:10 $GPRMC,081110.00,A,3716.04386,N,02309.32730,E,0.020,251.41,251114,,,A*63
        08:11:10 $GPVTG,251.41,T,,M,0.020,N,0.037,K,A*38
        08:11:10 $GPGGA,081110.00,3716.04386,N,02309.32730,E,1,08,1.62,21.2,M,34.3,M,,*6A
        08:11:10 $GPGSA,A,3,29,15,22,16,18,19,21,27,,,,,2.73,1.62,2.21*0F
        08:11:10 $GPGSV,3,1,09,29,05,119,28,15,13,058,44,22,64,179,34,14,03,155,25*7E
        08:11:10 $GPGSV,3,2,09,16,57,248,39,18,62,072,46,19,23,308,37,21,44,055,42*79
        08:11:10 $GPGSV,3,3,09,27,52,318,35*4E
        08:11:10 $GPGLL,3716.04386,N,02309.32730,E,081110.00,A,A*67
        08:11:10 $GPGRS,081110.00,1,-2.3,-0.9,1.4,0.1,1.0,1.8,-0.3,,,,*6F
        08:11:10 $GPGST,081110.00,1.7,,,,2.0,1.5,3.0*73
        08:11:10 $GPZDA,081110.00,25,11,2014,00,00*6F

        samble of nmea output from my lea-4t

        • Hi Jason, All,

          I am writing because I've been experiencing similar issues. In particular, I am using the APM2.5 with GPS NMEA and it does not work with the latest version of the flight  controller firmware, it says “NO GPS”. However, the same GPS works fine with older versions of the firmware, e.g., before May 2014, it say “GPS: 3D Fix”.

          Jason or anyone else, have you solved the problems about the GPS with NMEA strings?

  • I am now trying with a Novatel FlexPak6 (Leica GNSS have Novatel boards so it is the same messages anyway). 

    I have tried with GGA, RMC & VTG. I have read numerous different posts stating different message types so if anyone can give me a definitive answer would be appreciated.

    Baud set to 38400,N,8,1,N


    APM2.6 (Pins Right to Left) -> GNSS DB9 Male (Pin assignments from User Manual)

    Pin 1 (Red Wire) VCC - Not connected

    Pin 2 TX -> Pin 2 RX

    Pin 3 RX -> Pin 3 TX

    Pin 4 - Not connected

    Pin 5 GND -> DB9 Pin 5 GND

    Sample of the NMEA output


    • Could the precision of the data be the issue?

      I was looking at the output in the CLI and all I was getting was "............"

      I accidentally touched the RX/TX pins and then I got "NMEA Lat: 0, Lon 0, Alt: 0m, #sats: 0"  Whilst the pins touch, I get this repeatedly but as soon as they are not touching it goes back to dots across the screen.

      I tried it again with GGA, RMC, GSV, & GSA, same result.  I tested it with NMEAParser and all the data is there.3702531808?profile=original


  • John,

    ArduRover v2.46

    I have tried GP & GN. I can easily define this in my GNSS unit. I have also set my GNSS to GPS only. I will save some sample data and post it on Monday.

    Is there anyone in the Brisbane, Australia, region that would like to come around and give me a hand? I pay in Beer or Bourbon! :-)
  • I am keen to find out how to get this working. I am using a Leica GNSS receiver in a large rover project but I can't get it to read the nmea. I have it at 38400, sending GGA, GSV & GSA @ 5hz. I have checked the output with Putty and it all appears correctly but APM2.6 will not use it. I have set the GPS type to "5".
    • Jason,

      What is the talker id in the messages? GP, GN, GL?

    • Which version of firmware are you trying with? I know on Arducopter 3.2rc11 I can't use NMEA anymore.

This reply was deleted.


DIY Robocars via Twitter
RT @breadcentric: The handy bit about racing with self-driving cars is that one can type while the car is racing. Report from #AWSDeepRacer…
DIY Robocars via Twitter
RT @chr1sa: Our Bay Area @DIYRobocars meetup is now at 2,700 members. Next in-person events (in Oakland) are training day on July 17 and…
DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Jun 10
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
DIY Robocars via Twitter
RT @circuitlaunch: Last but not least, mystery guest @BostonDynamics Spot took to the track @diyrobocars He enjoyed the #brazilianbbq too 😂…
May 22
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race @circuitlaunch for @diyrobocars with @a1k0n Was busy in the morning and did not get a chance to tune camera…
May 22