Hi everyone, I searched this problem and there were a few hits. I've successfully calibrated the acceleration and compass but get blank bars when doing the Radio Calibration.  The radio is bound to the RX and all servos work.  I got HUD and GPS lock but can't proceed with initial setup without the radio calibration.

I'm using Pixhawk PX4 

MP 1.3.34

Arduplane 3.4.0

Taranis + 9XD (XJT module not yet installed)

X8R Reciever

Zeta Science FX79 Buffalo Flying Wing

One person who solved their problem reversed throttle on the radio.  Not sure how to do this on the Taranis.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Make sure you are plugging in the X8R into the S.Bus on the RX side and the RC.IN [NOT] the S.Bus on the pixhawk.

    • yup, that's how she's set up.

      do I plug my servos into the RX or the pixhawk main out?

      • You should power your servos via either your ESC's ubec or via an external ubec then run the signal/gnd from the ubec to AUX pins

        schema_gimbal.jpg

        • Any further thoughts on the radio calibration?  I'm stuck on this at the moment and can't move past.

          • some pics of your current setup would be useful.

            • I made a couple of videos:

              1. Initialization of the Pixhawk and bound X*R

              2. Mission Planner HUD and GPS view and Radio Calibration page



              YouTube
              • you are plugging in the wire to the RX in the wrong place. it needs to go on the bottom where it says S.Bus3702912393?profile=original

                the way you have it you're trying to use PWM and hawks do not support PWM

                • Thanks Craig, this got the radios calibrated.  Now when I plug servos into the Pixhawk I get no reaction like when it's plugged into the RX.  

                  I tried Martin's setup but nada.

                  • Did you hold down the red flashing arming button to arm the servos?

                    It's normal convention to have your elevons on channels 1 & 2 and the throttle on channel 3, not just from the servo main outs but also on the transmitter, I don't have a taranis but you should change your channels on your transmitter to follow that convention.

                    Also note that your transmitter should be set on normal aeroplane  mode with no fancy elevon mixing, (and definitely not helicopter mode) the pixhawk will do the mixing for you.

                    here is a link to the elevon set up section in the wiki. 

                  • http://plane.ardupilot.com/wiki/arduplane-setup/

                    head on over to that link and run down the info. I'm not a fixed wing flyer so I fear I can do little to help with the servos as I have never hooked one up before :(

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
2 hours ago
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
7 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
7 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…