I am currently getting no informaiton in MP.

I am new to this and trying to work through the issues


I went to the Terminal  and did a

test GPS


it comes back with "Init GYRO"

and hangs


any ideas



Views: 300

Reply to This

Replies to This Discussion

What version of the firmware are you running?


Ok when you go into terminal mode with your computer connected via usb cable does MP connect to the APM? Do you get any error messages?

I can connect without any errors. Just that the sensors do not move. .Altitude, GroudSpeed and all indicators are 0.0. Artificial Horiz does not move when I move the Quad.



Did you try reloading the firmware? If yes, then go to the terminal mode and then setup then erase and reset and then try reloading the firmware. If you have any custom PIDs you will need to save them.

Richard, I tried that with no luck. It loads the firmware fine but still nothing.
The test of the INS and compass fail so I beginning to believe that the board is dead.

I wish it wasn't so it's only 2 days old.

Interesting I just saw this

open a terminal


It states No dataflash inserted3COMPASS INIT FAILURE


I tried typing "Logs: I was going to erase them. It just hangs there,


I found this post where Al Lowrie states that he had the same problem. It was caused by low voltage from a regulator chip. It is supposed to have 3.3 v I have 0.24 volts. Looks like this chip is bad.



 Al Lowrie states

The TPS79133 (SOT23-5) chip is new on the APM2.5.2 board. It is a 3.3v regulator. I have only 1.3 volts at the output pins.

Where did you buy it? If its 3DR you should e-mail support and get an RMA. Support is bit slow from 3DR, be prepared to wait a bit. :(

Thanks Richard

I did buy it from 3DR. I have emailed them I am waiting for a reply. I am not sure they will cover this but I guess it's worth a shot.

When it worked (for about 15 min) It lifted off. I wanted to make it go to the left a little. I gently pushed the stick to the LEFT a hair and the thing shot to the RIGHT like a rocket and slammed against a fence. Do you have any idea what could have caused this?



What kind of radio hookup are you using?

I am using 3dr radio but it was not hooked up at the time. I did have it hooked up initially and it worked but I unhooked it for the test flight.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service