Optical flow on APM 2.5, where to land it?

Sitting down to get my 2.0 out and 2.5 in :-)

I'm trying to sort out where the Optical flow sensor gets landed now? I have been looking at the Eagle files trying to get a grip, but there are new components in the chain and I just can't get my head around where I pull MISO, MOSI, SCLK, ect...

If someone could help me out I'd be grateful.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Randy,

    I followed the suggestion you have given and also I read the pages you've suggested. Now my optical floe sensor is working good and I'm able to grab the images using python test script. I need one help that can you please tell me what are the PID values for OF_LOITER? I'm using APM2.5 with arducopter 2.9.1b firmware along with 3drobotics optical flow sensors for my f450 quad-copter.

    Thanks
  • Hi Randy,
    I tried to compile the code from master, but even this one also not compiling on my PC, can you please tell me about the check list to compile the code given in the master. Actually its showing error at Base_Bin, but after removing Base it is not showing any error at that particular line but after its giving an error at "flowSensor.print_pixel_data();" so please help me to compile this code successfully.
    Thanks in Advance.
  • Hi, I'm using APM2.5 with 3.0.1 firmware but recently i bought optical flow sensor, while verifying the test code it is showing an error like " no matching function for call to 'AP_OpticalFlow_ADNS3080_APM2::print_pixel_data()'". And I donno how to rectify this error even I included all the libraries and changes in the program code. but the same code is working well for APM1, I donno whats the problem for the APM2.5, Please someone help me to rectify this problem.
    Thanks in advance.
  • hi who can you send me the APM 2.5 hardware.  gavin1111@126.com

    I cann't open the file withe eagle software: http://stuff.storediydrones.com/Main_V25.zip

    thanks !

    http://stuff.storediydrones.com/Main_V25.zip
  • Problem solved for APM2.5 OPTICAL FLOW wiring 

    http://code.google.com/p/arducopter/wiki/AC2_OptFlow

  • Developer

    So I got it working although it needs more testing and vetting by some of the others on the dev + testing team before it gets into a release.  My guess is it won't make 2.7.4 which will probably be out in a week but the one after that.

    I've updated the wiki as well with the new instructions.  It's easier than with the APM2 although switching the little MISOLVL jumper from 5v to 3.3v is a bit tricky.

     

    The software changes were a bit tricky..there was a small bug in the restore/backup spi settings (we use different settings for different devices so we need to constantly save/restore settings depending on what device is talking at the time...on top of that I needed to make it auto-detect which SPI bus the sensor was on.  So now it first tries the regular SPI bus, then it tries the secondary one.

     

    If you're confortable with git, you can find it in the rmackay999-wip2 clone in the optflow25 branch.

  • Would you mind give me a copy of EAGLE Files of APM2.5

    garyliu6666@gmail.com

  • The bummer IMHO, is that there has been no response at all good, bad, or otherwise from 3DR at this point...

    XYOFscreenshot.jpgHere is a screen snippet of my log of the OF sensor just doing some hovering a round the front of the house... Haven't tried much to actually use the OF_Loiter or adjust the PID's, but figured one of you may know whether or not these are good numbers?

  • By all means try the jumper :-)

    (posting in dual threads at this point, here and the Wiki...)

    I did try landing the OF on the 3.3v side of the level shifter on the MPU-6000 side. It's a no go, as soon as you touch the SCLK line it all goes haywire. Just look at the horizon in the MP and watch what happens when you touch the SCLK with a test lead (not even hooked to the meter), the gyro drifts off and flips the horizon :-/

    But, please look into it as I am certainly no expert in microprocessors or SPI :-)

  • Hi, I'm having the same problem. It looks like on the APM1 that you used the 2560's ISP headers. But I read that on the APM2 there was some conflict with using those pins so you had to connect to the pins on the GPS shield. (Those connected to PJ0-2)

    I opened up Eagle too, to see where those pins go on the APM2.5 and they are entirely too small to solder anything to. I guess that means we need to connect it somewhere else. I'm hoping that the conflict that existed on the APM2 has been resolved and we can just hook into the ISP pins again. But then, I thought the 2 and the 2.5 were software identical, maybe that's not the case.

    Anyway, I really need to figure this out too!

    Thanks!

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…