I have set up my pixhawk and plugged all my channels correctly. However, my pixhawk will only army whe I pull the right stick to the bottom left. However I checked my params and my throttle is set to channel 3 already. How can I fix this. Also, when flying the quad (3dr diy quad kit) my quad constantly flips over and cannot even take off. I have checked the motor rotation and props and they are all correct. Also, when I do the ESC calibration everything starts up together. However about 10 minutes later the motors are out of sync again. Please help! Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi guys thanks for all the answers! I fixed the drone(bad pdb) and it flies now. However, it constantly drifts forwards drastically. When taking off it is fairly straight but after 5 seconds it begins to accelerate forward. In stabilize mode it drifts fairly slowly forward at a consistent speed. But in loiter mode it begins to accelerate forward and gets faster and becomes hard to control and will continue to get faster until it crashes. The take off is fairly straight up but it will begin to drift forward no matter the mode. The escs have already been re calibrated multiple times.
    • Hi Mike

      The drift in stabilize can be caused by two factors. You need to ensure your model is balanced correctly around the COG, move the battery to achieve this. Also the gyro calibration can cause drift. place your model on a level surface and view  the heads up display in the flight data menu in mission planner. the roll and pitch must be perfectly level. The loiter drift is more likely a compass or GPS issue. Is the compass head pointing in the correct direction in the flight data mode. Remember the compass heading will be offset by the true north amount in your area of the world.

      Good hunting

  • Check Mode 1 and Mode 2 of not only your radio, but what is selected in QGC or whatever you are using.

    Mode 2 is generally used in the US. It is easy to tell: the left gimbal on your RC unit doesn't spring back to the center when pushed up. This is throttle. In Mode 2 the arming procedure is bottom right to arm of the throttle gimbal.

    It sounds like this is where you have something wrong - between hardware and software config. 

    ESC calibration: there are so many ESCs with so many variables out there. What ESCs are you using?

  • "my pixhawk will only army whe I pull the right stick to the bottom left."

    that's because your RC control channel assignment is messed up, likewise, your motor connections are too, causing the flipping.

    read and follow documentation.

    • Here is a video
      https://youtu.be/IT8wHGiQrAw
      • Hi Mike

        Go back to the start of the setup procedure. Your machine is behaving very strangely. Have you gone thru all the required setup steps or have you simply put the hardware together. You need to upload quad firmware to pixhawk before any settings. Follow the the wizard in Mission planner in the Initial setup menu. Failure to do this will result in your quad not being flyable.

        Henny

    • Ok, however the drone does not always flip the same direction and it doesn't even lift off the ground before flipping, it just flips around 75% throttle.
      • Hi,

        What mode is your Tx?

        I'd suggest rechecking the radio calibration section, verify that the stick you are using for throttle moves the throttle.  Check that each of the other sticks move the bit you are expecting and in the right direction.  If not then fix that.

        Then I'd also use the motor test (with no props) and verify that each motor is correct.

        Chris

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Monday
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Sunday
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Sunday
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Sunday
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Sunday
DIY Robocars via Twitter
RT @DAVGtech: What a great way to connect why @diyrobocars community is so valuable and important! Have to start somewhere @IndyAChallenge…
Sunday
DIY Robocars via Twitter
RT @DAVGtech: https://t.co/GwkbSBjdGa
Saturday
DIY Robocars via Twitter
RT @DAVGtech: Good morning from @IndyAChallenge at @IMS. It was a late night, but worth it. Come see for yourself how the pass ended and ch…
Saturday
DIY Robocars via Twitter
RT @circuitlaunch: Robot fun this Saturday (23) at Circuit Launch! From 10am to 4pm. Lots of robots, autonomous car racing training, tech t…
Friday
DIY Robocars via Twitter
RT @chr1sa: 10 of these autonomous racecars will be competing tomorrow at the Indianapolis raceway
Friday
DIY Robocars via Twitter
RT @a1k0n: Sync'd @joshu's GoPro w/ my datalogging; video is 2.5X speed, Google imagery upper-right. Found out my track boundaries are WAY…
Oct 18
DIY Robocars via Twitter
RT @a1k0n: Also, at 45mph, the front tires literally blow up like a balloon and it doesn't have much front traction, so the car becomes fai…
Oct 18
DIY Robocars via Twitter
RT @a1k0n: Okay, some datalogs! Green dots are precalculated racing line (from my crummy optimizer -- it veers to the middle after 2 for Re…
Oct 18
DIY Robocars via Twitter
RT @a1k0n: Welp my @selfracingcars entry, hastily conceived heading filter and all, actually worked! Heading home, datalogs and videos to f…
Oct 18
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
Oct 15
More…