Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.


Views: 20274

Reply to This

Replies to This Discussion

for the nth time I looked and found it

all good now, many thanks David

Oh! well I am glad you found what you needed.

You would think it would be on the flight mode screen, right? But noooooo way.

Just to recap for others, I changed the flight mode channel under config/tuning under the full parameter list. Look for FLTMODE_CH. (APM must be connected first)

Where did you find it? 

I had looked in Mission Planned a few times with no luck, it must have been sticking in my face. I remember looking at the param's at the four major flight controls assignments which are the very next ones. DOH!

Funny, the first time I looked at the list in the wiki I found it straight up

Must be dyslexic or something :)

Thanks again for your help 

I would like to share my story to get this to work. I followed everything in this thread with no success so far. Until today.This might help other people as well.

I was struggling with getting EzUHF RSSI to work on MinimOSD-extra. Today I got another OSD unit, with the same result. That made sure it was not in the OSD I had already.

Then I went on searching. One more time through all settings. At the end I decided to take a good look at the SR2 settings. There's also a channel setting. I changed the value here from 0 to 8 and, voila, working! I changed it back, not working again. So, it was all in the SR2 settings. My Minim is connected through SR2. Since everything else was working here I never expected to look in that setting. I had to change some other stuff there to get it working in first place. This was before I started working with RSSI. Never thought there was a channel setting in there. Anyways, it works now.

The settings which work for me:

Mission Planner
RSSI_RANGE 3.3 (no matter, will not used anyways)
RC8_DZ 0
RC8_MAX 1793
RC8_MIN 1056
RC8_TRIM 1056

CH1 PPP Muxed
All others, default

RSSI channel Channel 8
RSSI Min 1056
RSSI Max 1793
RSSI Warning 60%
Of course in the panels also RSSI enabled


I know this is a thread relevant to Pixhawk, are your findings for a Pixhawk or APM setup?

This is for a Pixhawk setup.

Edit: For the APM I connected ch8 from EzUHF directly to the APM, slightly different setup. And slightly different setup in Mission Planner as well. As I remember, ME was excatly the same (maybe some different min/max values for RSSI min/max albeit).

It shouldnt matter.

The SR0 -> 2 values are how frequently various groups of telemetry values are sent from the FC out on the telemetry port. Naturally if no data is going out the Minimosd has nothing to report and draw.

Well, it shouldn't  ... but it does. SR2 had to be set already for me to have any data on the minimosd. The only data I was missing was RSSI, when everything else setup correctly. I really get no RSSI data when I don't set that highlighted option in my list. I tested that.

I have no clue why others never ran into that. Though that option does make sense to me. It's not for nothing it seems.

Once more to make clear, this was for a Pixhawk setup with a MUX ch1 on EzUHF with ONE 3 wire connected (ch1 EzUHF to RC PixHawk).

I've been at this for 2 days now with no luck. 3DR Iris+, Arducopter 3.2, MinimOSD Extra 2.2, EzUHF 1.5.

Using APM with Arduplane this configuration works, no problems. On Pixhawk/Iris+ and Arducopter, all data for osd is coming through except RSSI/LQ.  I've tried several different versions of minimosd and minimosd extra, no dice. EzUHF rx is set to PPM mux ch1, ch8 selected for RSSI, mimim configured to grab rssi on ch8. Single wire from Ezuhf ch1 to RC Pixhawk. I even tried several different values for SR2 as Remco Vos seemed to be in a similar situation here. Currently I have Telem1 connected to 3DR telem radio and minim, Telem2 is unoccupied (FrSky was occupying telem2 before I got rid of it).  Is there some type of limitation to telem1 that may be preventing just RSSI from coming through? Exhausted.

OK all is working now :)  If I re-read the thread from the beginning, I would have noticed one nice little detail that Steve Cain put in an earlier post:

"1) this works with 2.4r727... not the earlier releases"

DOH! I tried maybe 6 different versions of FW but not 2.4x. Using the PPM single wire setup described in my last post, all is working well including RSSI/LQ.  Big thanks to Steve Cain and all who posted in this thread!


I'm trying to only show the rxRSSI information (from the ezUHF) on the Mission Planner HUD.


Do you have an idea why i can't see it? the info is in the PPM stream at ch8 as usual.

Thank you



Because ArduPilot hasn't been able to understand RSSI via a PPM channel, many users of EzUHF with MinimOSD found themselves forced to use a passthrough via the channel directly to the MinimOSD to get RSSI. This meant that while you could see it in your OSD, you couldn't see it in Mission Planner and ArduPilot had no direct understanding of rxrssi for many setups.

I've redone the RSSI library in ArduPilot to give access to RSSI via a PPM channel, and some other improvements too like better ranging. This should all be going into ArduPlane 3.4 and ArduCopter 3.4.

With this in place you *will* get the rxrssi value on the Mission Planner HUD. I hope this helps the current messy situation somewhat. I personally have had a terrible time using the various alpha forks of MinimOSD, and the above PR allowed me to fall back to something more stable that works a bit better.

I would love to get beta feedback about the above changes; if you are able to, please try the latest ArduPlane 3.4 betas and let me know what you think.

(Also, I believe all the various MinimOSD versions have ranging issues and sign issues for RSSI, and perhaps some day I will look into fixing those as well.)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service