Pixhawk PWM input for RSSI (EZUHF)

Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.

Steve

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi, I am struggling to make ezuhf to work with fixhawk(rctimer pixhawk). But can't see my rc inputs over msn planner. Looks like the fixhawk board is not listening to the rx. Is there any step by step instruction for making it work with ezuhf rx? Thanks

    Steve Cain said:

    David,

    The PPM output from the EZUHF works nicely with both APM 2.6 and Pixhawk.  I highly recommend the EZUHF radio gear.  I have 4ch, 8ch lite, and two 8ch diversity receivers.  All are used for 8 channels (including the 4 channel one) via PPM sum output on channel 1.

    The current "issue" I am having is simply that the PWM (pulse width modulation) output for RSSI or Link Quality that can be sent from the EZUHF receiver  has to go through a special home made circuit to turn the PWM signal into a readable analog signal so the APM or Pixhawk can get signal strength or link quality to show up on my OSD.  I have used 1cell non-brushless speed controllers from hobby king for this for the last year with the APMs and I'm sure it will work ok with the Pixhawk too, I'd simply prefer a direct connection. (as they promised)

    I did hear  from Craig at 3DR that the PWM input for RSSI will be included in a future software release...he did not indicate which one... I have not yet looked to see if it is on the list for 3.2 which is at least 6 weeks away according to Randy.

  • Hi,I followed all the instructions here, thank you for that. I got closer to solvemy rssi problem.
    If I switch the transmitter off my rssi will only get 50% instead of 100% why? I did the "raw rssi" but the values do not match the 0% and 100%
    Thanks for the help anyway.
  • Hello,

    I'm trying to only show the rxRSSI information (from the ezUHF) on the Mission Planner HUD.

    No OSD.

    Do you have an idea why i can't see it? the info is in the PPM stream at ch8 as usual.

    Thank you

    CreativeBR

    • CreativeBR:

      Because ArduPilot hasn't been able to understand RSSI via a PPM channel, many users of EzUHF with MinimOSD found themselves forced to use a passthrough via the channel directly to the MinimOSD to get RSSI. This meant that while you could see it in your OSD, you couldn't see it in Mission Planner and ArduPilot had no direct understanding of rxrssi for many setups.

      I've redone the RSSI library in ArduPilot to give access to RSSI via a PPM channel, and some other improvements too like better ranging. This should all be going into ArduPlane 3.4 and ArduCopter 3.4.

      https://github.com/diydrones/ardupilot/pull/2770

      With this in place you *will* get the rxrssi value on the Mission Planner HUD. I hope this helps the current messy situation somewhat. I personally have had a terrible time using the various alpha forks of MinimOSD, and the above PR allowed me to fall back to something more stable that works a bit better.

      I would love to get beta feedback about the above changes; if you are able to, please try the latest ArduPlane 3.4 betas and let me know what you think.

      (Also, I believe all the various MinimOSD versions have ranging issues and sign issues for RSSI, and perhaps some day I will look into fixing those as well.)

  • OK all is working now :)  If I re-read the thread from the beginning, I would have noticed one nice little detail that Steve Cain put in an earlier post:

    "1) this works with 2.4r727... not the earlier releases"

    DOH! I tried maybe 6 different versions of FW but not 2.4x. Using the PPM single wire setup described in my last post, all is working well including RSSI/LQ.  Big thanks to Steve Cain and all who posted in this thread!

  • I've been at this for 2 days now with no luck. 3DR Iris+, Arducopter 3.2, MinimOSD Extra 2.2, EzUHF 1.5.

    Using APM with Arduplane this configuration works, no problems. On Pixhawk/Iris+ and Arducopter, all data for osd is coming through except RSSI/LQ.  I've tried several different versions of minimosd and minimosd extra, no dice. EzUHF rx is set to PPM mux ch1, ch8 selected for RSSI, mimim configured to grab rssi on ch8. Single wire from Ezuhf ch1 to RC Pixhawk. I even tried several different values for SR2 as Remco Vos seemed to be in a similar situation here. Currently I have Telem1 connected to 3DR telem radio and minim, Telem2 is unoccupied (FrSky was occupying telem2 before I got rid of it).  Is there some type of limitation to telem1 that may be preventing just RSSI from coming through? Exhausted.

  • I would like to share my story to get this to work. I followed everything in this thread with no success so far. Until today.This might help other people as well.

    I was struggling with getting EzUHF RSSI to work on MinimOSD-extra. Today I got another OSD unit, with the same result. That made sure it was not in the OSD I had already.

    Then I went on searching. One more time through all settings. At the end I decided to take a good look at the SR2 settings. There's also a channel setting. I changed the value here from 0 to 8 and, voila, working! I changed it back, not working again. So, it was all in the SR2 settings. My Minim is connected through SR2. Since everything else was working here I never expected to look in that setting. I had to change some other stuff there to get it working in first place. This was before I started working with RSSI. Never thought there was a channel setting in there. Anyways, it works now.

    The settings which work for me:

    Mission Planner
    CH8_OPT 0
    RSSI_PIN -1
    RSSI_RANGE 3.3 (no matter, will not used anyways)
    RC8_DZ 0
    RC8_FUNCTION 0
    RC8_MAX 1793
    RC8_MIN 1056
    RC8_REV 1
    RC8_TRIM 1056
    SR2_EXT_STAT 2
    SR2_EXTRA1 5
    SR2_EXTRA2 2
    SR2_EXTRA3 0
    SR2_PARAMS 0
    SR2_POSITION 0
    SR2_RAW_CTRL 0
    SR2_RAW_SENS 0
    SR2_RC_CHAN 8

    EzUHF
    PPM 8 LINK
    CH1 PPP Muxed
    All others, default

    MinimOSD-extra
    RSSI channel Channel 8
    RSSI Min 1056
    RSSI Max 1793
    RSSI Warning 60%
    Of course in the panels also RSSI enabled

    • RV

      I know this is a thread relevant to Pixhawk, are your findings for a Pixhawk or APM setup?

      • It shouldnt matter.

        The SR0 -> 2 values are how frequently various groups of telemetry values are sent from the FC out on the telemetry port. Naturally if no data is going out the Minimosd has nothing to report and draw.

        • Well, it shouldn't  ... but it does. SR2 had to be set already for me to have any data on the minimosd. The only data I was missing was RSSI, when everything else setup correctly. I really get no RSSI data when I don't set that highlighted option in my list. I tested that.

          I have no clue why others never ran into that. Though that option does make sense to me. It's not for nothing it seems.

          Once more to make clear, this was for a Pixhawk setup with a MUX ch1 on EzUHF with ONE 3 wire connected (ch1 EzUHF to RC PixHawk).

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…