Pixhawk setup problems - can't throttle up ESCs

Hello, I have 2 drones.. both DJI F550. Drone #1 uses Naza Lite controller and works great!

My second drone is controlled by a Pixhawk.

Pixhawk

OPTO 30A ESC

DJI 2212 motors

4S battery

Spectrum DX9 transmitter

Spectrum AR8000 receiver

3DR PPM Encoder

Problem #1

I now understand that the OPTO 30A ESCs cannot be calibrated. However, my PIXHAWK seems to be 'stuck' in ESC calibration mode. On boot, the LED blinks fast red/blue/yellow. When I push the safety button, I can throttle up and down and the motors respond. When I cut throttle to zero and turn the pixhawk off, the next time I power it, it appears to be back in calibration mode.

Problem #2 (what got me in to Problem #1)

Set up the Pixhawk and went for my first flight... on arm, the motors spin slowly, when I throttle up the motors increase RPMs but only by a little bit. At max throttle, there is not enough RPM to lift the craft. However, at any throttle setting (except idle), when I push on any other stick (elevator, roll, or even rudder) the (some?) motors increase RPM significantly (I believe they are attempting to respond to the control requests). Still there is not enough lift to get the craft off the ground, but you can see it leaning/attempting to roll or pitch. Someone suggested that I calibrate the ESCs... I followed the instructions on how to do that, but since the 30A OPTO ESCs cannot be calibrated, that didn't seem to help. And now I'm somehow stuck in calibration mode on the Pixhawk.

The motors/escs are good as when I connect them directly to the output of the RC receiver, they work perfectly.

Help! Any thoughts/comments welcome!

Chris 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have the same problem ... I assembled a Hexa, 750 KV motors, ESC DJI with firmware BLHELI, propellers 11x4.5 E grauphner coal PIxhawk PX4 FMU 3s battery ... I get to fly the hexa to 1 m. achievement and control, but not enough power to make a flight ... I revved and have no power ... 

    I replaced the controller by a Naza V2 and works well...

    But I want to run the Pixhawk

    • I'm used to the Mission Planer autonomous program to make my flight, and use for my planer Droid tablet field ... I still use these control programs? if I install the firmware QGroudControl ... and another question: as modified PID?

  • I have a similar problem...not sure.

    Everything works to me but the ESC calibration.

    The Pixhawk goes in calibration mode.

    Then it makes that long noise from the upper throttle recognized.

    I press the button but when i lower the throttle stick nothing happens. No lower throttle noise, light...nothing.

    May it be a FW problem also?

    {}s

    CreativeBR

  • So... what's the fix?
    • Hi Guys!

      My Setup is: All From Aliexpress.

      Alien H4 600 size Quadcopter

      40xx Motors - 14'' Prop

      80A esc

      Turnigy 9x with PPM encoder

      4s Batt

      Pixhawk ( Not Original )

      I had the same issue, and trust me i left it as it is for a whole year, i got really frustrated, until tonight when i took out everything and started re-calibrating everything from start.. I did everything required to operate my PIXHAWK, and it started working got GPS fix and all,

      BUT....

      Got the same issue of Throttle not increasing, Where as the Pitch/Yaw/Roll All responding at high speed..

      I tried THR_MAX parameter and set it to 1000 - 100% but that didnt solved..

      I tried ESC calibration but that didnt solve either..

      Then I saw Ali's & Chris Message of Changing the firware, I tried several previous version none of them loaded.. But his message did solved my Issue by ONE firmware that was one version older than the current versions...

      AND now i am so happy after an year that my Quad is working perfect....  

      Mine solved by changing firmware.. I think other guys should also do the same.. see if it works...

      Thank you 

      Sajid

  • Roll/Pitch/Yaw is working fine->issue only with throttle


    https://www.youtube.com/watch?v=oiDw6rok3mY&feature=youtu.be

    • Ali, your video shows exactly the same problem that I had. In the end, I started from scratch and reloaded the firmware. However, I had to load different firmware to get it to reset. By that I mean I had to load quad firmware on to my hexacopter, and then re-load the hex firmware. Another round of calibrations and setup, and I was in business.

      I can't say for sure how/why it was fixed, but I recommend starting again from scratch.

      Hope that helps.

      Chris

      • Exactly-Thnx for reply
        After several firmware updates issue disappeared.
        chears

  • Have the same issue here with my Quad 
    Spektrum dx6i (connencted via Sattelite receiver to Pxhwk)
    Pixhawk
    ESC 20A SK (RC Timer)
    MT 2216 KV900
    Telemetry
    GPS
    After upgrading to newest firmware-no more response on throttle
    Roll/Pitch/Yaw is working fine->issue only with throttle.
    Tried to setup PID, deinstalled installed MP, changed pixhawk (I have 3 PH two for the planes, one for the copter)
    Always same result.

    Could u solve it?

    Kind regards,
    Ali

  • Hey,

    I think your issue is similar to:

    http://diydrones.com/forum/topics/pixhawk-and-spektrum-dx8-setup-es...

    http://diydrones.com/forum/topics/pixhawk-refusing-to-arm-after-esc...

    My solution was using the firmware provided by http://www.qgroundcontrol.org/

    The 3DR one just didn't work.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sunday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…