I have a problem with Pixhawk plane wired and power as it says in manual with secondary backup power source and Zener diode. The plane was flying well while all autumn but at subzero temperature (-5C to -15C) the plane shuts down the motor in mid air.

 

I fly missions 60-80 min long. It shuted down the motor while first mission, I have changed motor and ESC. 3 missions later it crash again. I did test on the ground, and the motor would turn off after 5 min runnig. I turned the plane on in the office and this is what I saw: https://youtu.be/HMyRHtuzHXk

 (In the video the motor changes rpm by it self).

The motor start to spin, stop, working very in osculation way, or just spin. The way I fixed it, changed throttle output to port 6. It worked for another 3 missions, then changed to port 7 and so on.  So I thought that that something burns out in output port but yesterday I changed throttle back to port 3 and it worked well. Servos connected to PWM 1 and 2 work fine, the problems follows the throttle signal wire. I also get very bad compass variance and ARHS as soon as GPS gets 3D FIX, even after calibration.

 

All this problems appeared after I build new plane but with LIDAR-lite connected via PWM and updated to the latest Arduplane so it could support LIDAR.  

Views: 436

Reply to This

Replies to This Discussion

almost funny-fast about blaming software.

I could guess it's a knockoff clone without IO buffers ,only resistors , but it's strange anyway.  The real thing has level converters that act as buffers and make it impossible to damage an servo port within normal voltage operating levels.

Its original Pixhawk that I got from 3DR store...

If you say it's PWM outputs are destroyed one by one, check with oscilloscope what the ESC's are doing with the PWM pin, and it's voltage.

There is no kind of "bug" that can destroy a microcontroller I/O pin, as you can imagine, all microcontrollers are built so they can handle shortcuts and a lot of abuse on all IO pins, so no kind of software crash/error can destroy a pin unless external voltage exceeds limits.  then there are buffers and resistors that will save the day even if the limits got exceeded a bit.

...ooops  now I see that port3 "works again"   - then this means the ports are not damaged after all.. ?

Yes! I have connected throttle to all "damaged" ports to check them again and they were just fine(on the groung). But before, as soon as I turnd the plane on, with throttle connected to port 3, motor starts spining even without ARMING and pressing the red button which activates the plane. 

After all even if everything seems to work well I can't use my plane till I find the reason because it will happen again....

ok - disregard my comments based on suspicion of damaged ports.

Still, we can suspect the PWM voltage level , and/or noise on servo rail (from lidar) that could make ESC unhappy.

Pixhawk outputs 3,3v PWM , at higher voltages , some devices will not consiver 3.3v as logic "high".

For example if your servo rail is far above 5v - this can happen.  - Check servo rail voltage.

Also, I don't know the Lidar - due to it's pulsing nature it could generate noise that some devices don't like.

If you can reproduce the failure, try to connect a servo instead or in paralell with the ESC, see if one of them still works while ESC fails - or even better, check for ripple and noise using a scope.

Try removing Lidar, see if that's the cause of your problems.

Good idea about connecting servo in paralell!!! Did that but cant reproduce failure on the ground, its not that cold any more its around 0C - +5C. I think its some how related to temp. Have to wait for catapulte to arrive before I will do air test. By the way, have a look here http://diydrones.com/forum/topics/pixhawk-shuts-the-motor-in-midair... there are all the logs from bad flights, if you could have a quick look at them I would really appretiate it! Sounds like you really know how it works!

Could it be static? When there is enough static electricity accumulated ports go crazy? And when I change it to different port there is no static and everything work well till static accumulates on that port again?

I doubt it, depending on the irframe's ability to build up a charge, normal levels would easily be handled by capacitors and ESC protection in microcontrollers, and unless it's so powerful that components are permanently damaged, it should be more like a glitch.

Groundloops on the other hand, can cause strange things easily.

Hello! Did a test today. with Lidar disconected. Plane shuted the motor again, I swithed to FBWA, gained some altitude then switch to AUTO, plane flew for a bit and then shuted motor again so I had to swith to FBWA in then land it. So I guess this mean that ESC is working properly? Seems like problem inside settings or somewhere in Pixhawk... 

here is full log of todays flight.

https://www.dropbox.com/s/s8jn03y1q15din8/102_test1.BIN?dl=0

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service