Pixhawk with BaseCam (AlexMos) SimpleBGC Gimbal


Does any of you have experience to install a BaseCam (AlexMos) SimpleBGC gimbal to the Pixhawk, or have the technical knowledge to inform me if this is possible?

More information about the brushless gimbal controller can be found here: http://www.basecamelectronics.com/simplebgc/

I used this gimbal in combination with DJI Naza V2. I assume the Pixhawk can be used as well to control the gimbal (if DJI can do it, Pixhawk should definitely be capable). The gimbal controller board will take care of stabilizing the 2-axis tilt & roll. I only want to be able to control the camera pitch. Is this possible?

Thanks for suggestions.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am running a very similar set up. Turbo Ace Matrix-S with their gimbal, 6s, 12 volt voltage regulator, the BaseCam 8 bit flight controler, a Sony A7, and the Pixhawk Flight Controler. It took me months to get this it all working. I am using channel 6 to to control the pitch. I guess you got it figured out by now. Anyway nice setup. If it makes you feel any better I crashed mine 4 times, burned up 3 imu bords, murded 2 lipo batteries, and spent enough money to buy a second Turbo Ace. 


    • I'm sorry to hear about your difficulties Josh. I "only" crashed it once with the result of 1 broken propeller. I used to fly it with DJI Naza V2 but decided to change to Pixhawk because of all the worrying messages of fly-aways. I have the gimbal working (finally) and still need to get more experience in all the possibilities of the Pixhawk. Haven't tried follow me or waypoints yet. What battery are you using? Also the 6S 8000mAh from Turbo Ace? I purchased 2 of them and they both swollen up pretty fast. How much does your frame weigh including all gear? Mine is 3640 gram including gimbal, gopro 3+ and battery. Fly time about 17 minutes.

  • herewith some pictures of my quad project:


  • Yes! Finally some success. I couldn't figure out why I couldn't control Pitch of the gimbal using channel 8 of the Futaba RX. I decided to connect the 8th wire of the PPM encoder to the RX and see if I get any feedback on the Mission Planner "radio calibration screen". This was not the case. I haven't figure out why yet. The RX is programmed into Mode A which should enable all 8 channels. I double checked this, as it seems Mode B is selected. This is definitely not the case.


    I programmed my transmitter to use Channel 7 instead and saw I was getting feedback in the radio calibration screen. I connected the servo wire from Ch.7 to the gimbal and still couldn't control Pitch. After that, I just tried all possible inputs on the gimbal controller board and finally get it working when it was connected to FC_ROLL?? Obviously the labels of the schematics are incorrect. I was also able to get it working using the Pixhawk simply by moving the servo wire from the receiver to Pixhawk AUX1 output. Job done!

    Thanks everybody for the suggestions!

    The only thing left to figure out is why my channel 8 doesn't give any output. If you have any idea please let me know.

  • I'm still struggling to get the gimbal working. This is my set-up:

    - Futaba T14SG radio with Futaba R7008SB receiver (using Mode A: 8 channels)

    - BaseCam (AlexMos) SimpleBGC Gimbal controller board: Board 1.0 Firmware 2.2b2 (not possible to upgrade)

    - PPM Encoder board to be able to have the R7008SB communicate properly with Pixhawk (different topic)

    - Battery for the Pixhawk (6S) is different from the battery for the Gimbal (3S)

    I have connected 7 of the total 8 PPM Encoder wires to the receiver. The remaining channel 8 of the receiver will be used to control the camera Pitch.

    3701860126?profile=originalA servo wire is connected from RX Channel 8 to the SimpleBGC board RC_PITCH (red wire disconnected).

    3701859870?profile=originalI have programmed the Gimbal controller board as follows:

    3701859892?profile=originalOn the Futaba radio, I programmed Channel 8 to be used with the Left Slider (LS).

    3701860060?profile=originalWhatever I'm trying, I can't control the camera pitch using the radio LS. The Gimbal itself is working properly, it does maintain a stable position when moving the quad frame.

    Any idea what I'm doing wrong?

  • Sorry I did not give an update on this topic yet. I'm still waiting on my PPM encoder board from 3DRobotics to connect the Futaba R7008SB to the Pixhawk (currently it doesn't work with the stable FW). I hope to receive it this week so I can test during the weekend.

This reply was deleted.