Pixhawk wont spin motors after arming...

Just installed a pixhawk on my QAV540 quad, and for some reason it will not spin the motors after arming and in manual mode. I know the ESCs and motors work cause if I hook the ESC directly to chanel 5 of my receiver I can move the throttle up and down and control the motors. For whatever reason the Pixhawk doesnt spin the motors at all...

Any ideas?

Thanks,

Scott...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • Are you plugging the esc directly into the receiver? If so then check to see if your TX and rx are linked. What receiver do you have?
      • Hey Dave!

        I have my esc's into my pixhawk as the instructions advice and my receiver (ar8000) connected through ppm encoder to pixhawk, I'm able to do radio calibration just fine except for making the motors spin.

        They don't spin in esc calibration nor in arm mode, I'm able to arm but motors just sit still

        Thanks again

        Javier
  • I know this is late...but just for reference for people with the same problem.  I had trouble calibrating my ESC's and getting the props to spin up at arming.  HERE IS THE SOLUTION (thank you gregmaan)

    -When doing ESC calibration (throttle at max), on the second time you plug in the battery (when it usually makes the arming beep after the music tones) press the safety button AS SOON AS IT STARTS UP, before the musical tones stop.

    -Do the same thing for arming, you have to press it ASAP or else your props won't spin.

    Major fistpumping when I figured this out!!!!! YES!!

  • Hi Scott, were you able to fix the problem? I have the same problem.

    thanks.

    • I fixed my probem:When I use the safety switch directly after powering it worked for me.And after upgrading to 3.1.2 RC 1 the problem was gone.I think It was not the main firmware. I also updated the io part (press and hold safety switch before powering up) after the firmware flash.The problem is that some escs are not armable, if they get no signal within the first x seconds of powering up.I think I got my problem while playing with qgroundcontrol and flashing original firmware.After that I had this issue.Seems to be a known problem when switching from original firmware to the ardupilot firmware.

      • Think i found a good description of the procedure:

        http://ardupilot.com/forum/viewtopic.php?t=5744

      • It seems i am facing the same problem, currently with 3.1.2, after switching from pixhawk firmware.

        Do you have any hints/links to the procedure of update the io part?

        - Do i have to be in the process of flashing the firmware, or can i do it any time, after the installation?

        - If i have to do it after the flashing, is it the first reboot after the tones?

        tank u

  • Sorry a bit off topic.
    Can the pixhawk calibrate esc
    Same way as apm 2,5.
    If anyone knows Ty
    Cheers
  • Moderator
    There are a whole series of pre-arm safety checks.
    - do you have telemetry? If so, planner is probably reporting what isn't right.
    - do you have a good 3d GPS fix?
    - did you use the hardware arming switch?
    - did you calibrate your radio?
    - did you perform a tx arm command (yaw hard right for three seconds?)
    - are you in stabilize when arming?
    Etc.
    • I am trying to convert my quad to a hex, but the motors will not spin. My logs seem to show that everything is perfect.  I got a gps fix while attached to my computer, then attached the battery, then while the tones were playing, I pushed the safety button. I also modified this procedure, by pushing the button immediately after the tones. I always got a green light, gps fix, musical tones, good arming tones, but the motors will not spin. I redownloaded quad firmware, then hex firmware to ensure a good hex flash. I calibrated the two new escs (all six successfully flashed with simonk firmware). Everything seems perfect for the new hex configuration. Since there have been so many reports of this problem, hopefully 3DR will address it in a wiki.  What could I be doing wrong? Log attached.

      2015-07-24 13-14-16.log.xml

      2015-07-24 13-17-29.tlog

      2015-07-24 13-17-29.rlog

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…