PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • T3


      All fine with the new updates. No (visual) problems with MOT_PWM_TYPE=2.

      However, my copter is much to sluggish for some aggressive flight tests (I almost crashed it) and there is too much wind at the moment for autotuning.

      I have a 2min log with IMU_FAST as proposed by Randy enabled if someone is interested. Let us know if we should enable anything else to log for further tests.

    • Maybe I found another issue, my quad is quite stable with 3s Lipo, but If I replace it by the final 4s Lipo, it starts to oszilate.

      I tried to lower the p-values  (ATC_ANG_PIT_P and ATC_ANG_RLL_P) but they seem to have no effect!

      Am I using the correct P-value?

      Does anybody have a hint for me?

      Best Regards


      • Developer

        I tried to lower the p-values  (ATC_ANG_PIT_P and ATC_ANG_RLL_P) but they seem to have no effect!

        the ones you should lower are the rate gains, not the angle gains. The key gains that would cause oscillation are and ATC_RAT_RLL_{P,I,D} and ATC_RAT_PIT_{P,I,D}

        Ideally you'd do an autotune and let it sort out good gains. Otherwise it would be worth having a read of the tuning docs.

        • Thanks for the hint, after using the correct PID-params, it was easy to tune it :-) 

        • Oh, Andrew, I lowered 

          ATC_ANG_PIT_P and ATC_ANG_RLL_P to 2

          should I move it back to 4.5 and start adjusting down the others you mentioned

          ATC_RAT_PIT_P and ATC_RAT_RLL_P to 0.05

          I just assumed it was because my quad was so small I needed it lower.

          Guess I did it wrong too :-(
          I will go re-read the docs and do an autotune this weekend then,


          • Developer

            Hi Edgar,

            Yeh, you should drop all your ATC_RAT_XXXXXX by 3/4. That should be a good start.

            • Okay, its flying great, but anything to make it better ;)

              I tried acro but noticed it does not flip and has way too much leveling, really I dont want any leveling.
              Would simply turning the ACRO_TRAINER to 0 allow it to flip in both roll and pitch and maintain the angle?

              Complete Parameter List — Copter documentation
    • I just tested the build of today.

      Unfortunately my ESCs (afro 4 in 1 20A) do not initialize with that build, I do not hear the final beep, instead they are beeping constantly every 2 second or so).

      All three types (0,1 and 2) behave the same.

      I uploaded the build of yesterday, and they work fine again (tested type 0 and type 1).

      best regards


      • Developer


        Do you have a safety switch connected? Did you press it so its not flashing? Previous builds didn't honour the safety switch.

        If its still not working with the safety switch then please try setting BRD_SAFETYENBALE=0 and see if it then works for you.

        Cheers, Tridge

This reply was deleted.