PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Oh interesting, thanks..
          That might explain why on some flights, my OSD went blank, too...  I think it was on flights where I push the throttle, so might have been causing a bit of a brown out for the OSD.

      • Same issue here.  Telem2 takes a fit and won't work.  Moving to Telem1 seems to solve the problem.  A real shame, as Telem2 is the easier port to access for me.

        • What a pitty I'm building mine and telem 2 is the easier port for me too, When I finish I post results, thank's to alert.

          • Radiomodem on Telem 2 is working at the moment for me; first plug.

            • Thanks!  I think my port is dead, in my case..  Lot of crashes between the last time I used it a few months ago, and now... My guess is some wires got crossed and I got 5 or 12v on the serial tx line.

              There's not a separate serial enable disable type setting in the code is there?  Only SR values and baud are the only settings related to the telemetry ports, right?

              • SERIAL1_PROTOCOL?

  • Has anyone else noticed issues with SR1, SR2 values...  I had trouble connecting with telemetry to Serial 2, and discovered that its SR2 values were as listed below.  All other values for SR1, SR3, etc were all zeroes.  Oddly enough, after saving my config, changing the values for SR2 to 0, saving them on the copter and comparing what I had just saved in MP, the values for SR2 were saved in SR1 - the SR1 values were previously listed as all 0s.  Telemetry is working more reliably on Serial 2 with all zeroes.  

    Values Before Changing them all to 0

    SR2_EXT_STAT 2
    SR2_EXTRA1 4
    SR2_EXTRA2 4
    SR2_EXTRA3 2
    SR2_PARAMS 10
    SR2_RAW_SENS 2
    SR2_RC_CHAN 2

    Values from compare:

    SR1_EXT_STAT 2 0 True
    SR1_EXTRA1 4 0 True
    SR1_EXTRA2 4 0 True
    SR1_EXTRA3 2 0 True
    SR1_PARAMS 10 0 True
    SR1_POSITION 2 0 True
    SR1_RAW_SENS 2 0 True
    SR1_RC_CHAN 2 0 True
    SR2_EXT_STAT 0 2 True
    SR2_EXTRA1 0 4 True
    SR2_EXTRA2 0 4 True
    SR2_EXTRA3 0 2 True
    SR2_PARAMS 0 10 True
    SR2_POSITION 0 2 True
    SR2_RAW_SENS 0 2 True
    SR2_RC_CHAN 0 2 True

  • Hi everyone, I have a big problem, I'm working on a quad prototype which uses a pixracer as autopilot and Spektrum's AR8000 satellite reciever to get the radio control but i have an issue :

    I can't get rc values to appear on Mission Planner or QGroundControl, both with arduCopter and PX4 flight stacks. I tried to power the reciever with a power supply and to read the signal on an osciloscope, the signal seems to change while à move the sticks so I guess the controller gets the raw data from the reciever but it doesn't seems to decode/transmit it via USB port.

    The DX8 Transmitter and the reciever are binded via DSMX. (Orange LED fixed on the reciever)

    (the reciever is connected with the pixracer's cable : 3.3V, GND ans RCIN plugged into the RC connector.

    Has anybody encountered/solved this problem?

    Thank you very much, Nicolas.

    • Nicolas/Rodney,

      Have ya'll been using 3.4 or 3.3.3? I don't believe it works w/ 3.3.3, but should work for 3.4, since the update discussed here. Since that discussion, I've had a Spektrum satellite w/ DX8 on my pixracer and it's been working fine. 

      -Scott S

      • Thank you for your answer, We tried to update the ardu firmware from the git, the problem is still here, we don't get any signal in the channels, (we now have the channel monitor on QGC but nothing moves) is there some configuration to apply to the pixracer in order to make it read spektrum's data? We only plugged the pix to the computer by a USB cable, uploaded the firmware and calibrated the gyros, the RCMAP seems to be OK.

        Tu update the firmware, we juste built the master branch from github, it built firmware_v1, v2 and v4, with only v4 compatible for upload.

        Thank you, Nicolas

This reply was deleted.