Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have been connecting and connecting to upload custom firmware to Pixracer for some time now and never have a problem.  I did have a problem one time when switching from the PX4 flight stack to the APM flight stack.  I used QGround Control to kick it and from then on no issues.  More than likely its a USB hardware/driver issue as the Pixracer shows up on a different port with a different name.

    • I noticed that the Pixracer shows up as a different port and name to the pixhawk when connected via USB, which suggests a different driver and hardware set to the pixracer.

      I doubt it is USB driver related on the computer side when Pixhawks connect just fine.

      Did you mean USB driver hardware/driver issue on the Pixracer side?

      What computer are you connecting with?

      • So 3 hours later...

        Installed latest mission planner (.38) on 3 windows 10 PCs. 1 windows PC has the Zadig USB driver for the Taranis Plus, one might have, and the other definitely does not.

        Installed AC3.4 dev on the PixRacer on one of the rare times I was able to connect. Confirmed installation since Mission Planner reports is and the safety light flashes.

        Cannot routinely connect to the FC. 1 in 20 times I can connect.

        Tried the ESC calibraton several times, but no tones after the first long one.

        I also notice this weird thing on booting the PixRacer where sometimes the piezo sound is loud and sometimes it is muffled. Something is up with this brand new, grounded board. May be a return to manufacturer I think.

        I also notice that people refer to firmware 3.3.4. This does not seem to exist for Arducopter. I have only seen 3.3.3 and 3.4dev. (ctrl-q) are people who refer to 3.3.4 mistaken?

        • Hi Justin,

          The USB driver is the same for the PixHawk as the PixRacer. When I have intermittent issues, I try 2 things.

          1. Make sure you are directly connected to the USB port on the computer.

          2. Try a different USB cable.

          I was testing a batch of PixRacers just this morning when after the 10th board, I was unable to connect. Turned out my USB cable finally gave up on me. It is detected by Windows but indicated the device descriptor could not be found. Replaced the cable and problem solved.

          • Hello Phillip,

            I have just ordered a second pixracer and other parts from your site. Express post was chosen. The order number is 616.

            Could you please contact me privately to discuss this order please?

            Justin.

          • 1. Check. Direct connection, no hubs.

            2. Tried a second cable since I noticed the first one was damaged. Will try a third cable tomorrow sometime.

            Based on Joe's comment above, I am now unclear as to whether I was trying all this with 3.3.3 or 3.3.4. Will check tomorrow also. I was definitely using 3.4dev (ctrtl-q) for most of the USB testing.

            For the last three hours, I have had some really wierd and inconsistent USB connections. Sometimes the params load fast, sometimes slow, sometimes not at all (and Mission Planner shows whole sections as greyed out.) Sometimes the PX4 shows up in the com port name and sometimes it is something different without that included. Connecting seems to be more successful when going through the initial setup wizard. I think that handles handshaking better.

            Anyway, done for now. Will try again tomorrow with a third USB cable and maybe also try 3.3.4.

            • Tried the PX4 stack.

              Qground control reports: "vehicle did not respond to requests for parameters".

              Every time I have reported I have been using 3.3.3 it was in fact 3.3.4 as reported at the very top of Mission Planner.

              So have tried 5 USB cables, 3 Mission planner ground control stations, 2 firmwares (AC3.3.4 and AC3.4dev), Qgroundcontrol and cannot connect to 1 Pixracer.

              It's gotta be the pixracer.

              I really like board even though I have not got off first base with it. Going to get a second one at the same time for my brother. This should also aid troubleshooting in the future.

              • Solution to the USB connection problem.

                With expert instructions from AUAV I removed all unrecognized unused and hidden USB devices (USB Serial Bus controllers) on the Windows 10 device manager. Selected yes when promoted to remove drivers and software.

                Now can connect reliably to the Pixracer via USB on a Windows 10 PC.

                At one stage I removed the USB keyboard and mouse, but unplugging and plugging back in got them working again.

        • Look at the notes on the first post of this thread.

        • One note is that the ESC calibration on Pixracer with the current 3.4 dev is broke.  It was working for a short time but some new changes were made that broke that feature.

This reply was deleted.

Activity

gotham liked gotham's profile
yesterday
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…