Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • Here are all of the logs from yesterdays flights, the last three are the most interesting in my opinion. 

      the first 2 logs have autotune attempts, the second produced good usable roll/pitch values. 

      https://drive.google.com/folderview?id=0ByNP743-FSrrZjN6dzc0akNBUnM...

    • Developer

      @Artem,

       Setting ATC_RAT_YAW_FILT to 20hz does NOT survive reboot, it defaults back to 5hz after power cycle.

      I have reproduced this and I've pushed a fix to master. Thanks for letting us know!

      I haven't looked at the other issues yet

      • It would also be good to default that for Y3 along with

        ATC_SLEW_YAW = 18000
        ATC_Y_MAX = 54000 - 100000 (MP description says max 54k but when set to 100k it seemed better, so I've left it at that) 

    • couldn't upload in the original post. 

  • Logs for Dev's...   Running a copy of arducopter 3.4 I downloaded/installed on 5/21.
    Still some alt_hold trouble.  Unpredictable behavior.
    It still makes small yaw adjustments, and occasionally some sudden bursts of power/increases in altitude. 

    Also, my telemetry connection (standard modems, not wifi) has become very unstable..  I connect, it starts downloading params at a normal speed, then slows down considerably.. and when it is finished transferring the parameter list, the connection level is down around 10%.  It seems random.  I have checked my antennas, and they are all OK.  Power cycling either modem (pc or copter) fixes the trouble, and I get 99% reception again.
    But, I have to mention, I haven't done a lot of research in to it, and maybe my modem has developed an issue..
    Also, MissionPlanner updated itself since the last time I used it, so maybe it's a MP issue... 


    Small log had a few sudden bursts of power, and it's short, so should be easy to see the issue.
    The larger log was having some of the telemetry connectivity issues, and some of the yaw movements, and one or two sudden bursts of power in alt_hold.  Also, at the end of the log, it was just sitting stationary, and EKF went red on velocity..  I'm sure it's a GPS thing... but happens often.

    • I can also confirm that in the 1 in 20 times I can connect to the Pixracer via USB, the params download speed is sporadic. Sometimes normal, sometimes slow, sometimes does not seem to finish, when really it has.

    • Apparently there is a problem w/ file upload at the moment.. Just tried from my internet connection, as well as a clients w/ a completely different provider, and cannot upload the files...  
      Will try again in a few hours..

      • Still can't access the home page or upload my log files, but want to mention something... 
        I know I say bad things about this GPS all the time, but it's worth mentioning again..  (because it causes SOO many subtile issues and I have wasted months figuring out it's the GPS the first time I used one of these)
        I have 2 RTFQ mini m8n gps's, and both are getting about 6-10 satellites and have poor position hold capability under the tree in my back yard.  (10+ meter drifting around)
        I plugged in my HK m8n, and I get 20 satellites and totally solid loiter.  (maybe 10cm drift)

        All of them are using the same configuration. (I checked in the Ublox config program)

        • FWI, I purchased a Neo-M8N off ebag for a GREAT price. Tried to update the FW on it with u-center and couldn't. Found out the Ublox chip it was a clone (that's a surprise). From that point on I decided I wasn't buying clones anymore if at all possible. I have a unit coming from CSGShop, a place recommended by forum member gervais. My belief is  that's one place that should not be skimped on. There is a lot of money in the air to be relying on a cheapo GPS unit. Just my $.02 YMMV

          • did you find a suitable case for that CSGShop gps? One thing that is nice about many of the cheaper eBay etc gps's is the form factor as they are inside a case with a nice encased single wire harness which looks cleaner and the single encased wire is far less prone to issues than a home made jumper. But I hear ya... if the gps is garbage it's the old garbage in garbage out scenario. 

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…