Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Developer

          One thing may make a difference is that my throttle channel is mapped to channel 2, probably because I run Deviation with Orange DSMX receiver.

          ahh, I should have asked about that. In that case the critical numbers are RC2_MIN, RC2_TRIM and RC2_MAX.

          Assuming RC3_* is where PX4 stores the PWM range for the ESCs, then you should set:

          • RC2_MIN=1055
          • RC2_TRIM=1055
          • RC2_MAX=1962

          • Hi Andrew. 

            There is no difference in other RC calibration values between PX4 and APM versions. here is the channel 2. 

            RC2_DZ,30
            RC2_MAX,1964
            RC2_MIN,1054
            RC2_REV,1
            RC2_TRIM,1054

            1 1 RC2_DZ 10.000000000000000000 9
            1 1 RC2_MAX 1964.000000000000000000 9
            1 1 RC2_MIN 1055.000000000000000000 9
            1 1 RC2_REV 1.000000000000000000 9
            1 1 RC2_TRIM 1055.000000000000000000 9

            When I have time, I will try to see PWM output with the oscilloscope and may see what is the difference between two during bootup. My ESC are rebranded and I can only guess that it is Xrotor 40A and they supposed to  use SiLabs chipset and who knows what firmware. Looks like they are sensitive to something that APM outputs.

  • I receive this error configuring my PixRacer compass in MP. I have no external Compass or GPS connected. What can I do to correct this? 

    Pre-arm compass offset too high

    I have no external Compass or GPS connected. 

    MP 1.3.37.5 build 1.1.5974.64976

    APM:Copter 3.4-dev(50908edc)

  • I receive this error configuring my PixRacer compass. I have no external Compass or GPS connected. What can I do to correct this? 

    Pre-arm compass offset too high

    I have no external Compass or GPS connected. 

    MP 1.3.37.5 build 1.1.5974.64976

    APM:Copter 3.4-dev(50908edc

    • One or both of your compasses have a high offset value say about 500 which is bad.  Caused by metal or magnet near by.

      • It doesn't seem to matter where I try and calibrate them, I get the error. And yes, both show above 400 no matter what I do. Any suggestions?  

        • Do you have the buzzer connected? If so can you try calibrating without the buzzer connected. The buzzer needs to be placed as far away from the flight controller as practical.

          • now i'm getting compass not healthy and the animation in the live calibration window are not spinning ... both compass windows are not spinning... Is it possible that my board is bad? 

            • No external compass? 
              I think you'll find a lot of us only trust external compasses, and disable the internal ones.. So, I'd start there, to at least be at the same point the rest of us are.. 

              Then, there was, and maybe still is and issue w/ the 2nd internal compass.  It would never calibrate correctly, and had to be disabled.  (the joys of alpha software testing). 
              So for me, I disabled compass #3 before calibrating.  Maybe with no external, you'd need to disable compass #2.  And be sure to load the latest version of APM Master before you begin. 
              And, for me, things that cause compass interference, are screws or servos or buzzers or antennas near the flight controller.  Or externally, I cannot calibrate anywhere in my home, and almost nowhere in my yard....  In my home I have speakers in every room.. And even being a few meters away from the speakers, the compass still points the wrong way.  In my yard I have some iron fencing and a porch w/ a metal roof, and that causes trouble for about 10 meters around those areas...  The magnetometers are certainly a pain to get calibrated correctly in the wrong environment!

          • no...buzzer is not connected...it doesn't matter what GC SW I use to calibrate, I still get the prearm error. Any suggestions?  

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
Saturday
More…