Hi

Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don't use a Futaba receiver, thereby I can't replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn't "see" the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED "pre-arm check failed" (which makes sense ;)

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is "found" by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions ...

Thanks a lot in advance

Felix

Views: 40063

Reply to This

Replies to This Discussion

Mark Slater (http://diydrones.com/profile/MarkSlater) had this problem and has made some headway with it i believe.

Shouldnt it be on SBUS  not RC BTW?

Have the same problem with the same receiver and a futaba T14SG. I would appreciate any help. I connect my rx  from pin8 to RC pin on pixhawk but not recognized :(

Can't find where MarkSlater faced the problem :(

I have same S-BUS connection problem R6303SB receiver to Pixhawk.

ArduCopter 3.1.1-rc1 is out in the Mission Planner’s Beta Firmwares link.

And It should be improved for Futaba SBUS receiver support. However, it looks no help for me.

Actually, the connection of FrSky TFR4B is just fine.

The problem is that for some reason i can't upload another version of arducopter in pixhawk through missio planner nor apm2 ... someone said that he put another firmware but don't know where and how

It is very tricky to update Pixhawk, even if you have right procedure.

Please follow this instruction.

http://copter.ardupilot.com/wiki/common-loading-firmware-onto-pixhawk/

You need patient.

But, I do not understand to update APM firmware problem,

Most of the trouble comes from damaged micro USB cable and connector.

Please try by new micro USB cable.

@ Colin: the receiver has to be connected to the RC port of the Pixhawk, the Pixhawk's SBUS port is SBUS OUT

Those who use the same receiver - could you double check, that you put your receiver in the right mode (enabling SBUS) - to rule out one possible source of error.

https://www.youtube.com/watch?v=iDqLrvf6Il4&list=PLoTP7cKJ_UO9q...

Felix

I would like to know the receiver model number of Futaba that is operational with Pixhawk.

There is no S-BUS compatible servo or gyro other than Pikhawk in my hand.

I have followed the instructions carefully, but at the stage where i m waiting for the firmware to be uploaded to pixhawk , i always get the message that it couldn't be uploaded. Sometimes i plug-unplug the USB sometimes not (to see if this works).

I have also installed and unistalled the drivers and the software many times but no luck. Having tried in many computers. Doesn't upload. All have windows 7.

Thx for your reply anyway.

Sorry, he didn't post it here, i meant you should message him.

Felix, from the PIXHAWK overview on the APM Copter wiki, its a bit confusing,this is why i thought it was sbus input

  • Interfaces
    • 5x UART serial ports, 1 high-power capable, 2x with HW flow control
    • Spektrum DSM/DSM2/DSM-X Satellite input
    • Futaba S.BUS input (output not yet implemented)
    • PPM sum signal
    • RSSI (PWM or voltage) input
    • I2C, SPI, 2x CAN, USB
    • 3.3 and 6.6 ADC inputs

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service